Retroarch USB controller debugging

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Retroarch USB controller debugging

This topic contains 6 replies, has 5 voices, and was last updated by  mikeylopez 2 years, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #87508



    Using bits and pieces I found on the internet I managed to mostly get two usb controllers (USB N64 controllers) working with emulator station and retroarch.

    Although I have programmed both the same, I am having one issue where only in one joystick the down buttonbutton seems to triggers two events- a down and a “fire”- whereas on the other the down, only does down, and the fire is the down button on the C buttons.

    All other mappings works fine.

    I’d appreciate any assistance in debugging etc.



    ok, so I’ve tried analyzing the


    file, and I only see a player 1 config, no player 2 config


    I’ve tried adding the following commands to be able to exit the emulator

    input_enable_hotkey_btn = “7”
    input_exit_emulator_btn = “9”


    but they don’t work either… what are the correct files/locations to debug?

    Does anyone have the proper config files for two retrolink USB N64 controllers with the analogue joystick as I am unable to get that to work?



    Ok, so I upgraded to 2.5 of the emulator, and it mostly fixed my first issue- now the two generic N64 USB controllers work (except for the analogue joystick) my retroarch.cfg got corrupted

    and the second issue was due to the wrong type of “quotes”

    – How can I get the analogue controls working? When I run the

    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    Here is what was visible on the screen when I was programming the controller

    Up D-pad
    Joyaxis moved: Axis 1, Value -20945
    Down D-pad
    Joyaxis moved: Axis 1, Value 23002
    Left D-pad
    Joyaxis moved: Axis 0, Value -20174
    Right D-pad
    Joyaxis moved: Axis 0, Value 22745

    and here is what was added on

    input_player1_joypad_index = “0”
    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_btn = “h0up”
    input_player1_down_btn = “h0down”
    input_player1_left_btn = “h0left”
    input_player1_right_btn = “h0right”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “4”
    input_player1_r2_btn = “5”
    input_player1_l3_btn = “7”
    input_player1_r3_btn = “7”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+0”
    input_player1_r_x_minus_axis = “-0”
    input_player1_r_y_plus_axis = “+1”
    input_player1_r_y_minus_axis = “-1”



    Hey there, I have the exact same problem with the quotes. How did you get the right quotes? is there an easy way to copy and paste the other quote “



    When you do a command like this:
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    It hardcodes your controller to the retroarch file – which itself is probably set to read the auto files. These guides should help you sort out multiple controllers:

    RetroPie help guides -->
    Please read this before asking for help -->



    Is there a way to configure the C buttons and Z trigger for RetroArch? Mupen64plus configures this automatically but RetroArch doesn’t seem to have the mappings.



    @badviper, did you manage to fix this issue of mapping the z and c buttons?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss