RetroArch ROMs Crashing randomly

Tagged: , ,

This topic contains 8 replies, has 2 voices, and was last updated by Profile photo of petrockblog petrockblog 2 years, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #86836
    Profile photo of frikk
    frikk
    Participant

    Hi guys,

    I have a fresh install of RetroPie (v2.3), and the only modification that I’ve done is added a few ROM files (that I own legally) for SNES, and set up my iBuffalo controller (using the provided setup script which worked great). I’m on a Raspberry Pi B (512mb RAM).

    Emulation station works great, and I’m using the default SNES emulator (which I believe is RetroArch). The games are beautiful, sound works great, controllers are highly responsive.

    The problem is that I’m getting intermittent crashes on my games. Super Mario Allstars seems to be the worst — Mario 3 crashes quickly, typically before I can complete the second level. Super Mario World (in the same ROM) seems to be more stable, but crashed after about 20 minutes. Same w/ the stand alone Super Mario World ROM. I tried playing EarthBound, and the first 2 times I played it (for about 20 minutes each) it was fine, so I thought it may have been a bad ROM file. But then last night it crashed on me too after about 15 minutes of a new session. Donkey Kong has not crashed yet, but I’ve only played it once.

    What happens is the game just crashes back to the console, where you can see the boot messages for the rpi and a few startup scripts for emulation station, then emulationstation loads back up to the SNES menu. Basically the same as if I had exited out of the game (which I have mapped to select/start on my controller config).

    So my questions are:

    * Is there a log file I can look for?
    * Would changing emulators help? I’d rather not change since RetroArch works so well (when it isn’t crashing)
    * Would updating to the beta version of retropie help?
    * Has anyone else experienced this? I’m running a pretty vanilla setup here.

    The only thing different is that I do have a bypass of the USB regulator on my chip, but that’s never caused system instability and all it does is remove the current cap so that the Pi can have a full wifi chip if needed (which I am not using currently).

    I’d love to hear any tips on what I could try. I’m an advanced linux user and I don’t mind getting my hands dirty. Thanks!

    #86837
    Profile photo of petrockblog
    petrockblog
    Keymaster

    please download retropie 2.5.0 – 2.3 is very old now and a lot has changed since then.

    disable overclocking with raspi-config and see if that helps (maybe will narrow down the problem) ?

    Check your power supply – what are you using to power ? have you tried another psu ?

    #86838
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you can download the latest image from my google drive – https://drive.google.com/open?id=0B_knGioK16E6TlVpa3hmRi1PRHc&authuser=0

    #86842
    Profile photo of frikk
    frikk
    Participant

    Awesome. I guess I just naively assumed the “Downloads” section was up to date. This is the perfect response, I’ll try it tonight. Also, thank you for your drive link.

    Using a wall power supply + no over clocking.

    #86843
    Profile photo of petrockblog
    petrockblog
    Keymaster

    What are the specs of your wall power supply? Have you swapped in another to rule it out ? Anyway, try that image and let me know. Thanks.

    #86870
    Profile photo of frikk
    frikk
    Participant

    I’ll try the image tonight, thanks! It’s a 2A power supply so it should be good.

    #86925
    Profile photo of frikk
    frikk
    Participant

    Hey buzz,

    The new image works great, thank you! But apparently you can’t have it all…

    I’m no longer crashing, and the system appears to be stable. This is good!

    However, on 2.5 (compared to 2.3) SNES is slow, and the sound is sputtery. I’d say about 15% slower than full speed. Interestingly enough, 2.3 was perfectly fine and no sound issues.

    I’ve tried overclocking, which does help, but I don’t have heatsinks so anything beyond the second overclock setting causes the system to lock up after a few minutes.

    I’m going to try disabling “rewind” to see if that helps (from the sound wiki).

    I’m looking forward to eventually getting the rpi2, but I’d like to see this working at 100% first! Thanks for the help!

    ps: i love that on 2.5, the controller config files are already set up and the select/start exit is already set up too.

    #86928
    Profile photo of frikk
    frikk
    Participant

    Ended up finding out that in /boot/config.txt changing hdmi_safe=4 boots me up in 720p, which really helps keep the CPU caught up.

    Went ahead and tried overclocking with volt=6, assuming that under volting is why the pi was locking up. This was the biggest boost, everything runs great and no lockups.

    Changed hdmi_safe back to default (uncommented out) and so far everything is running great at 1080p. So it looks like overclocking is really the best way to get it working properly on RetroPie 2.5 with the Raspberry Pi B.

    #86932
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you can adjust the video mode of most emulators and even per rom by pressing M or X before the emulator loads

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar