RetroArch config script not saving config file

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie RetroArch config script not saving config file

This topic contains 2 replies, has 2 voices, and was last updated by  cikey 2 years, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #106560


    General info
    Pi Model: B
    RetroPie Version Used: 3.0
    Built From: SD Image
    USB Devices connected: Original SNES controller (converted to USB with NES/SNES kit)
    Config details:

    I’ve got some controllers converted from an earlier project using NES, SNES, DB9 (Atari/SMS/Genesis) chip.
    (My chip has firmware 1.4)

    I know the controllers work as they should (tested in windows) and they do work in Emulation station. They also register when I use the RetroArch config tool, but the configuration file is not saved in /opt/retropie/configs/all/retroarch-joypads folder even though the scripts states that the file has been created.

    I’m thinking its related to the naming of the chip, but I’m not sure. The controller identifies as: (S)NES/Atari_USB and I’m not sure if the “.” or “/” might be a problem in the file name.

    Thus I’m sure my controller works, I just don’t have any idea how or where to write the config file (and what to name it) to make the controllers work in retroarch.

    I have sent Raphnet an email about the problem but not received an answer.
    I have also tested my setup with another USB controller and that works as expected.

    Additional information:
    When testing the controller with Jstest command, every button registeres as follows:

    UP: 0 (-32767)
    Down: 0 ( 32767)
    Left: 1 (-32767)
    Right: 1 ( 32767)

    Start 3
    Select 2
    A 4
    B 0
    X 5
    Y 1
    L 6
    R 7

    Bonus question: I’ve also got some spare kits from Retro USB ( has anyone got experience using these with RetroPie?

    If you need any more information, I will be happy to provide it.

    Thank you.



    Sorry for the haphazard reply but I’m at work so I am pretty much going to copy and paste something I wrote for a friend last night, most of my formatting gets cut out when I paste it here though. I hope this helps:

    General info
    Pi Model: RasPi 2
    RetroPie Version Used: 3.0
    Built From: SD Image
    USB Devices connected: DragonRise inc. SNES style USB gamepad. Basic USB HID keyboard.

    How to manually configure controllers in RetroPie 3.0

    So I was running into a problem where the auto config was not saving the config files when I ran it on certain controllers on RetroPie 3.0. I needed to find a way to manually configure my controllers and save/manage the files in case I wanted to switch controllers at different points. I’ve listed some useful locations below:
    -This is the cfg file that emulationstation uses for the main UI. Delete this file if you want to setup a new control scheme for emulationstation when you restart. (NOTE this wont do anything for game controls)
    -This is where the .cfg that the RetroArch snes emulator uses in game.
    -This is where new configs are generated by the Configure RetroArch RGUI
    -This is where the retropie setup script is located (just in case you dont already know)

    NOTE: any step that starts with $ is what you should type at the command prompt but omit any text with a # before it. The # is letting you know that the text following it is just a note for your information and is not meant to be input into the rasberry pi.

    Also, anytime you run a command with sudo in front of it you may be required to input your password, I didn’t put this in the directions so just keep an eye out for that.

    1. press F4 from emulation station
    2. $ cd RetroPie-Setup # Change directory to the retropie setup dir so you can run the setup script.
    3. $ sudo ./ #run the setup scripts.
    4. select option 3 “Setup / Configuration”
    5. select option 316 (this is probably subject to change) “retropie configuration menu for emulationstation”
    6. press esc key until you are back in command line then type emulationstation and hit enter.
    7. You should now have a new menu tab called retropie, select that
    8. select “configure RetroArch / Launch RetroArch RGUI
    9. when browsing this with your Keyboard ‘z’ should be back and ‘x’ should be use/enter/confirm/ok
    10. go down to “settings” and press x
    11. go to “input user 1 binds”and press x
    12. Make sure your keypad is plugged in and highlight each option in this screen, press ‘x’ on your keyboard the press the button on your gamepad that corresponds to the option you highlighted.
    13. once you are done setting all of your buttons press ‘z’ twice to go back to the main screen.
    14. Have a pencil and paper ready for this next part. Highlight the “Save New Config” option and press ‘x’
    15. write down the file name that was saved. It should look something like “opt/retropie/configs/all/RetroArch-0923-030622″ (Basically what you just wrote gets saved as a backup file and you must go to /opt/retropie/configs/all/ and manually rename your file to retroarch.cfg)
    16. Now select “Quit RetroArch” and press ‘x’
    17. You should be kicked back into EmulationStation, so press ‘F4’ to go back to terminal.
    18. $ cd /opt/retropie/configs/all/ #this is the dir where your .cfg file and any new .cfg’ are located
    19. $ ls -l #this should populate an easy to read list of the config files you need to work with
    20. $ sudo mv retroarch.cfg retroarch.cfg.backup #save your old .cfg file just in case you want to swap back
    21. Locate the file you made in step 14-15, it should look like RetroArch-0923-030622. If you dont know which file it was or couldn’t write it down, the naming convention seems to be “RetroArch-[DATE]-[TIMESTAMP]. You will use this in the next step.
    22. $ sudo cp RetroArch-NNNN-NNNNNN.cfg retroarch.cfg #replace the NNNN-NNNNNN with the actual numbers of the file you created. This will copy your new .cfg file into the space that RetroArch uses for playing games.
    23. $ ls -l #make sure you see a retroarch.cfg file.
    24. $ sudo reboot

    Load up some games and have fun!





    Thank you so much! This worked like a charm!

    I also used nano to change retroarch.cfg in regards to the hotkey buttons

    input_enable_hotkey_btn =”N”

    input_exit_emulator_btn = “N”
    input_reset_btn = “N”
    input_menu_toggle_btn = “N”

    (N beeing the corresponding button on my joypad.)

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss