retroarch autoconfig multiple controllers

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project retroarch autoconfig multiple controllers

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of rastendo rastendo 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101636
    Profile photo of jojco
    jojco
    Participant

    Hello !

    I’m using retropie 3 BETA 4 on a raspberry pi 2

    I have a probleme when i try to configure a ps3 wireless controller with the retroarch autoconfig script.

    My controller works in emulationstation, and works when i do a jstest.

    I’ve been previously using the autoconf script to configure 2 differents xbox wired controllers and the problem is that, now, even if I only plug my ps3 controller and launch the script to configure it, it still detects my xbox controllers like if they were plugged in (but they are not) so it tries to configure them instead of configuring my ps3 controller.

    Here is what i get when i only have the ps3 controller plugged in:

    RetroArch: udev_add_pad: [udev]: Plugged pad: Xbox Gamepad (userspace driver) (0000:0000) on port #0.
    RetroArch: udev_add_pad: [udev]: Pad #0 (/dev/input/event2) supports 0 force feedback effects.
    RetroArch: udev_add_pad: [udev]: Plugged pad: Xbox Gamepad (userspace driver) #2 (0000:0000) on port #1.
    RetroArch: udev_add_pad: [udev]: Pad #1 (/dev/input/event3) supports 0 force feedback effects.
    RetroArch: udev_add_pad: [udev]: Plugged pad: PLAYSTATION(R)3 Controller (0000:0000) on port #2.
    RetroArch: udev_add_pad: [udev]: Pad #2 (/dev/input/event4) supports force feedback.
    RetroArch: udev_add_pad: [udev]: Pad #2 (/dev/input/event4) supports 16 force feedback effects.
    RetroArch: input_joypad_init_first: Found joypad driver: "udev".
    Found joypad driver: udev
    Using joypad: Xbox Gamepad (userspace driver)

    So i checked /dev/input and found out that I have 3 controllers (js0, js1, js2) even when only one controller is plugged in. I tried to reboot but even after that, always 3 controllers.

    Is there a command to force “unplug” the controller or something ?

    thank you very much!

    EDIT
    I tried rebooting my pi with nothing plugged in, and when emulationstation starts it says ” 2 gamepads detected”
    So its really these 2 xbox controllers that i installed before that always appear plugged in for some reason…

    EDIT 2
    I typed the command dmesg and got these two lines in the end :

    [   15.963533] input: Xbox Gamepad (userspace driver) as /devices/virtual/input/input0
    [   15.964258] input: Xbox Gamepad (userspace driver) #2 as /devices/virtual/input/input

    seems like it mount some “virtual” device ? i have no idea what that is but it seems to be a part of the problem!

    OK A NEW EDIT because i’m finding informations little by little:

    I typed the command “ls /sys/devices/virtual/input/”
    and it returned : “input0, input1, mice”

    then i typed “cat /sys/devices/virtual/input/input0/name” it returned :
    “Xbox Gamepad (userspace driver)”

    so now im sure, i have 2 virtual xbox controllers (and a virtual mouse too…)
    like if the fact that i once plugged them create them as virtual forever.

    i still can’t get rid of them…

    #101644
    Profile photo of jojco
    jojco
    Participant

    Alright i found the problem. It was in the rc.local file.

    this line was automatically added when i installed my xbox controller :

    #xboxdrv --daemon --id 1 --led 2 --deadzone 4000 --silent --trigger-as-button --next-controller --id 2 --led 3 --deadzone 4000 --silent --trigger-as-button --dbus disabled --detach-kernel-driv$

    there’s something in that command that make my 2 xbox controllers ALWAYS present even if unplugged.

    i replaced this line by

    xboxdrv --trigger-as-button --id 1 --led 3 --deadzone 4000 --silent &
    sleep 1
    xboxdrv --trigger-as-button --id 2 --led 4 --deadzone 4000 --silent &
    sleep 1

    and now it works !!

    #104957
    Profile photo of rastendo
    rastendo
    Participant

    Just wanted to thank you for updating your post when you found the solution. I was having the same issue and this worked for me as well.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar