Retro Pie 3 – Exiting games

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Retro Pie 3 – Exiting games

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of supergameco supergameco 1 year, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #104677
    Profile photo of supergameco
    supergameco
    Participant

    Hi, I have just installed the latest version of RetroPie 3 and can only seem to exit games when playing MAME roms. Any other system (SNES, NES, MegaDrive, etc) just won’t exit games when I press the escape key. I haven’t tinkered with any of the settings, it’s a fresh install. Any ideas?

    Thanks.

    http://supergameco.com.au

    #104681
    Profile photo of herbfargus
    herbfargus
    Member

    If you have a joypad plugged in it overrides the nulbinding of the keyboard and you need to use the joypad hotkey (default select) in order for ESC on the keyboard to work to exit.

    But you should just be able to use select+start on your joypad to exit. If you’re having problems with that see this post:

    3.0 – How do I exit a game back to the emulator now?

    #104683
    Profile photo of supergameco
    supergameco
    Participant

    Thanks for the reply. No joypad plugged in, just the keyboard.

    http://supergameco.com.au

    #104685
    Profile photo of supergameco
    supergameco
    Participant

    I’ve just realised that if I press the select+start equivalents on the keyboard it exits the game. Any way to change this to the escape key?

    http://supergameco.com.au

    #104691
    Profile photo of herbfargus
    herbfargus
    Member

    There is a way you can modify the hotkey behaviour with the setup script in option 3 you could try the options there and see if that sorts it out.

    #104692
    Profile photo of petrockblog
    petrockblog
    Keymaster

    When configuring controls on a keyboard, retropie 3 uses the same hotkey style as with a gamepad. This is so that when using arcade style controllers that map to keypresses, RGUI menu and exit is available. It also stops conflicts with other hotkeys that may be defined – which could be accidently triggered before.

    You can force the hotkey behaviour by adjusting configs/all/retroarch.cfg or by using the retroarch input configuration menu in retropie-setup and choosing an alternative hotkey scheme.

    #104740
    Profile photo of supergameco
    supergameco
    Participant

    Appreciate the help, I’ll give it a try.

    http://supergameco.com.au

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar