Retro Pi

Home Forums RetroPie Project Peoples Projects Retro Pi

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of celticjet834 celticjet834 2 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5650
    Profile photo of snoddad
    snoddad
    Participant

    Hey all, after having my Pi laying around collecting dust, I figured I would see what some projects are out there to try out. Turns out I picked this. My goal is to see old DOS games and other old games alike that would have a chance at running on the Pi. I’ll use post as a guide for anything that can or can’t be done in my free time. I would love input to help guide me and to improve on the project. Thanks.

    Games:

    -Doom2 – “Playable” (Running super fast, need to slow it down)

    -Alone In The Dark – “Working” (Runs VERY slow in DOSBox, Still need to set up the disk in Rpix86)

    -Jack In The Dark – “Working” (Runs a little better than Alone In the Dark)

    -Commander Keen – “Playable” (Episodes 1-5 Run like a charm in Rpix86)

    -The Incredible Machine – “Playable” (Runs OK in Rpix86, Is a tad bit slow, but still OK to play)

    -Descent – “Working” (Runs SUPER Slow in DOSBox, will not run in Rpix86 Due to Virtual Memory not supported)

    -MAME – “Playable” (Using MAME4All-Pi)

    -Duke Nukem 3D Atomic – “Playable” (Works great, transitions have a shuttering effect however)

    Wish List:

    -Will have to attempt some indie games like Organ Trail or Uplink (games that are also on Android that I think have little resource demand)

    Info:

    -Fixing keyboard controls for MAME/RetroArch Link

    -Changing to MAME4All to run MAME roms fasterLink for MAME4All on RetroPie.

    Pictures:

    (Place holder for later pictures)

    #14927
    Profile photo of joshfong
    joshfong
    Participant

    How did you get Commander Keen 1-5 working? I’m struggling a bit on that. My copies are from Steam, if that helps.

    #24950
    Profile photo of snoddad
    snoddad
    Participant

    @joshfong

    Here are the things that I have done for Rpix86 that may or may not be of some help.
    – I updated the version of Rpix86 located and replaced the one in /home/pi/RetroPie/emulators/rpix86

    – I edited/created (can’t remember) the Start.sh under /home/pi/RetroPie/emulators/rpix86 and added -a0 to force HDMI sound.

    – From Steam I copied Base1-Base5 to /home/pi/RetroPie/roms/x86

    Other than that they run fine. Let me know what issues you are still having.

    #24956
    Profile photo of snoddad
    snoddad
    Participant

    Since I can’t edit the original post I figure I will give a update.

    – I have The Ultimate Doom, Doom2, Final Doom, and Master Levels for Doom2 working and running using prboom instead of using the default. The reason behind this is for multipule reasons.

    1. Game Music will run with out having to add the sound files manually.

    2. Master Levels will not run without Doom2.wad included, RetroArch has no way of adding more than one wad file.

    3. Also looks nicer when running.

    With that said I edited the es_systems.cfg to make a custom page for each one and the run command for Doom, Doom2, Final Doom is: prboom -iwad %ROM%
    Master levels is: prboom -iwad “Location of doom2” -file %ROM%

    – Alone in the Dark is now running on Rpix86 with the abandon ware version. Sounds are weird and not like the Disk version. The issue with the disk version is that mounting the CD puts no Volume label on the drive and Alone in the Dark looks for a disk named INFOGRAM. For now this is fine for me.

    – Quake 3 is running with the instructions from HERE edited es_systems.cfg to add custom page.

    -ScummVM currently has all of my beloved childhood games like Putt Put and Pajama Sam. Works just fine and dandy.

    – I added some SNES, GBA, GBC, Genesis games as well with few issues (Controls for genesis have to be edited in the .cfg file.)

    – I might put some of this stuff on GDrive (No games sorry.) for the changes that I do and instructions on how to use them. I have not been keeping up on this project and have found that there is a new version that is currently being tested with. I have not touched this and all of my progress is with the old one (1.10). I will see about the new one when some issues are resolved. Thanks and have fun!

    #52350
    Profile photo of billtheunjust
    BillD

    Can you post your full .sh for doom? I had a doom.WAD, but when I try launching from emulation station it black screens then returns to ES. If I exit ES I can see an error, I think it’s segmentation fault. I’ll try to post the full error when I can.

    #82594
    Profile photo of celticjet834
    celticjet834
    Participant

    Hello…although I just joined the petrockblog forum, I’ve been tinkering with RetroPie for about 1 month and “no sound through HDMI for rpix86” is an issue that I’ve run into and have yet to solve.

    However, I can see that one of the posters above suggested to do this:

    “I edited/created (can’t remember) the Start.sh under /home/pi/RetroPie/emulators/rpix86 and added -a0 to force HDMI sound.”

    Could you perhaps post exactly what you modified to get HDMI sound to work for rpix86? I’m very new to to this world of Raspberry Pi/DIY/programming, so exact details (perhaps attaching the file itself?) would be most helpful. Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar