Remove xpad and use xboxdrv instead to stop controller light flashing constantly

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Remove xpad and use xboxdrv instead to stop controller light flashing constantly

This topic contains 4 replies, has 2 voices, and was last updated by  floegeolf 4 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15948

    trimmtrabb
    Participant

    Could anybody tell me how to stop the xpad driver from loading in image 2.2 as I want to use xboxdrv instead to stop the controller lights flashing constantly. Thankyou

    If you have found the solution to your problem please mark the topic as resolved.

    #16237

    trimmtrabb
    Participant

    Sorted 🙂 To stop xpad loading edit raspi-blacklist.conf:

    sudo nano /etc/modprobe.d/raspi-blacklist.conf

    Add: blacklist xpad

    Then reboot and install xboxdrv:

    sudo apt-get install xboxdrv

    Then follow instructions in the wiki: https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    (I used method 1)

    If you have found the solution to your problem please mark the topic as resolved.

    #16695

    floegeolf
    Participant

    I would also like to stop the blinking on my wired xbox controller, so I followed your solution.

    Before I tried that, the controler was recognized by emulatorstation and I was able to configure it to play games. But the LED kept on flickering (on my Ubuntu Desktop PC the controler is also recognized and the LED stays lit on Player 1).

    After I blacklisted xpad and restarted, it wasn’t recognized anymore by emulatorstation, so I installed xboxdrv, chose option 1 from the How To and restarted. xboxdrv cannot find my controler 🙁

    So I removed everything I changed, back to xpad and it works as before, with the led flickering. I guess xboxdrv does not find my controler (an unofficial one, recognized by dmesg as a logitech device).

    What I don’t understand: What makes ubuntu recognize it and switch the led to player 1 while retropie won’t?

    Any help?

    #16699

    trimmtrabb
    Participant

    Xboxdrv does appear to have support for 3rd party Logitech pads: http://pingus.seul.org/~grumbel/xboxdrv/

    When you edited rc.local did you make sure a wired pad is specified? (–id instead of –wid)

    If you have found the solution to your problem please mark the topic as resolved.

    #17000

    floegeolf
    Participant

    Yes, I did use -id instead of -wid. And I already compiled the latest xboxdrv on a previous retropie installation, which didn’t recognize my controler either. In fact, the manufacture id is from logitec, in demesg it’s recognized as a Microsoft Controler. It seems as if the device if is not recognized correctly (at least no on my retropie installation, as Ubuntu does recognize it – but I don’t see the difference between both. Too much of a newbie 😉 ).

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.