Rebooting endlessly rainbow screen

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Rebooting endlessly rainbow screen

This topic contains 20 replies, has 4 voices, and was last updated by  Morpheus 2 years, 10 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
  • #87362


    Hello everybody!

    With all the necessary equipment at hand, I followed the steps of the tutorials I found on the internet.
    But when I put my SD card in RaspB + he keeps rebooting endlessly. A colored screen, like a rainbow, and are up various codes. But it happens over and over. Could someone help me? thank you

    follow the link of the problem

    Not notice the background music. ¬¬ Has a circus in front of my house! >.<



    Which version of retropie are you running?

    (Make sure you are running the latest 2.5.x version)

    how are you powering your pi ?

    (I have seen reboots like this due to power supply issues.)

    have you enabled overclocking ?

    (Can also cause instability depending on settings)

    do you have any usb devices connected?



    I’m using version 2.3 (RetroPieImage_ver2.3.img) on my Raspberry B +

    I am feeding with a source that:

    I could not even give upgrade. I just put the image with the win32diskimage and put in Raspberry. I turned on all the equipment. After that it is as it is in the video.

    I connected the keyboard and wireless mouse, and the Xbox control receiver.



    As mentioned – please use the latest 2.5.x image and we can go from there.



    I’m running the 2.3 here also, very happy with it also. Should not be the problem.

    Tried rebuilding your SD-card?
    I’ve got some weird issues with my old image too, but guess every case is different. In my case it seemed that the formatting of the SD card didn’t went as it should. Anyways, it’s worth trying to make a new image on your sd from scratch.

    An unstable power source also produces strange behaviour or reboots as said here before. Maybe there’s an other one or you can borrow one to test if that’s the issue?



    where I can download? I just found the Beta version here on the blog.

    I tried to picture 2.5 Beta blog. Without success! The same problem.

    If you think that is the power supply, which you indicate me?
    I’m using to specifications:

    Please confirm that my steps are correct:

    1) format SD card in FAT32
    2) install the image with the win32diskimage
    3) remove safely
    4) put in Raspberry
    5) connect the equipment and finally turn on the power

    I’m doing something wrong? NOOBS is necessary? I’m forgetting some stage? some file?



    All info including partitions, mbr clean after formatting?
    That was my problem by just formatting with osx disk utility. I had to specifically rebuild / clear mbr too. But unfortunately I don’t use Windows so sorry can’t help with that. Maybe Windows also had global formatting instructions in command line?

    Wish I could help you but can only tell proper osx way…sorry.
    Ends for me here. Further steps you named were correct. Only correctly burning retropie image and it should work.



    I’m using keyboard and wireless mouse Microsoft 800. Would be the problem?

    tested with all possible images.

    2.5 Beta
    2.5 Buzz Image

    all failed. all the same problem. reboot and rainbown screen.

    I will try to install NOOBS.

    I need some operating sitema as Raspbian, or NOOBS to install Retropie?



    try with another PSU. Also ry booting without USB device etc.




    I tried to installed NOOBS and again without success.
    It just caught on rainbow screen.
    I will try with keyboard and mouse usb wired.
    Another Power Suply, I will try during the week. But it is according to the requirements.

    And about the 2.5x image? where i can download?



    I thought you said you already tried that ? It’s on the main download link on the menu on this page.



    Maybe your psu is faulty, or poor quality/knock off etc. with any sort of issue like this, the first thing is to rule out the psu. I have seen reboots before with usb devices connected when the PSU was not sufficient. Also without the usb devices, to make sure it isn’t related to them.



    yes I tried with all the images available on this blog.


    hmm I’ll buy a new PSU this week.
    But you think I should use a more powerful? more like 3A? (i dunno if this is possible)
    Or just another model whit same powerful 5DC 2A?



    2a is fine. You don’t have another USB power supply/charger around to test ?
    did you try without the usb devices connected ?



    no, i dont have!

    One more thing:

    When I turn on the Raspberry and try to sync my Xbox wireless controller, the receiver does not light the LED, even when I hold the button. This may show that the error is really the PSU, right?

    Yeh i did whitout all usb



    Hey buzz

    where i download “loader.bin”?

    cz I dont have this file in my SD card. and my green led flash 4 times.

    I need download this?



    Hi Galego, im also new to the RPi scene but I may be able to help. And in Portuguese, should you need. (yeah, BR willing to help.)

    You should be able to boot with any of the SD images you tried.
    Since they did not work, maybe you have some defective hardware. Let’s hope its the PSU.

    As people have said, 2A is good, as long as its really 2A. Not some knockoff copy or “generic” PSU. Try another one. If you can, try an original PSU from a high energy consuming device, like a tablet.

    You may also try the NOOBs image, but reboots like you have, with different images don’t use to be software related.

    Make sure its not an overheating or over-clocking issue.
    The 2.5 Images comes with no OC by default so it should not be that also.

    I’m not here all the time, so it may take a while to answer.

    B+ | 2 B



    oh man! ty for reply!
    I need your help, if u can! >.< (você é BR?) Se for eu mandei uma mensagem privada pra você!

    tomorrow I’ll try to change my PSU.

    But when you say can be a hardware problem, you refer to SD or in RaspB +?



    I still do not know if the case is resolved.
    But following the guidance of the members @buzz @Morpheus and after 2 days of research on the internet really believe that the problem is PSU.
    Tomorrow I will try a new PSU and give the final opinion.
    For now look at the case and the resolution of the problem in this site:



    I made a huge research on the internet.

    The problem really was the PSU.

    But in my case I changed the PSU and to no avail, as a less power.

    My PSU was not defective and the specification was correct.

    My problem was the USB / micro USB cable. He was damaged or was weak.

    Ty guys
    I thank everyone who helped me



    After a lot of testing, he identified the flaw was in the USB cable of the PSU, not the PSU itself. It’s all fine and he is now doing progress on his RPi project.

    B+ | 2 B

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss