Random Activity on JS3

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of petrockblog petrockblog 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20446
    Profile photo of rhorne
    rhorne
    Participant

    Hey guys,

    So I bought a PetRockBlock GPIO adapter and soldered it myself. I’ve tested it’s working using the button press test and both my SNES joypads are fulling working according to JSTEST on JS0 and JS1.

    The problem I’m having is that if I test JS3 every now and then it detects activity across all buttons at the same time. It’s the very briefest of flickers but this means I can’t configure Emulations Station properly because when I’m trying to configure a controller, this flicker of activity happens and ruins the setup.

    Does anyone know what might be causing this?

    #20460
    Profile photo of petrockblog
    petrockblog
    Keymaster

    It sounds as if some other service is emulating another joystick device. You can get an overview about the services with the command sudo service --status-all. The RetroPie GPIO Adapter needs only SNESDev to be running as service.

    #20462
    Profile photo of rhorne
    rhorne
    Participant

    I think you might be right. I had SNESDEV and the Game Con driver both running simultaneously. Disabled Game Con and am now just trying to work out how to configure my controller for use in a game.

    #20464
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Ah, I see – gamecon and SNESDev do interfere with each other, so that only one these two should run at one time. Good to hear!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar