[Question] Return to Emulationstation from Emulator/Game – Only controller!

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project [Question] Return to Emulationstation from Emulator/Game – Only controller!

This topic contains 7 replies, has 5 voices, and was last updated by Profile photo of escher escher 2 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #82230
    Profile photo of niss3
    niss3
    Participant

    Hello!

    I’m trying to use RetroPie to create an arcade machine. So far it’s going pretty well!

    The one problem I’m currently having is that once I’ve booted up RetroPie, selected a console and a game with my controller, played the game for a while and decide that I want to change game, the only option I have is to reboot the whole Pi.

    Well, either that or plug in a keyboard so I can click Escape. I’ve been thinking about solutions, and one of them would be very nice if I could change the function of “Escape” to another key. Then I could easily put a “choose” game button anywhere, but it doesn’t work with the escape button, sadly. Is there a way to change the key for quitting the current emulator and return to emulationstation?

    Thanks for all help!

    #82231
    Profile photo of RetroMarine
    RetroMarine
    Participant

    Type this into your retroarch.cfg: input_enable_hotkey_btn = input_exit_emulator_btn =

    This creates a hotkey button i.e. 8 = select button on a snes controller, and 9 = start button, so that when you hold select and press start it will exit emulator. Remember to only put a numerical value after the =

    #82236
    Profile photo of niss3
    niss3
    Participant

    Hey RetroMarine, thanks for the answer!

    I’ve just now tried setting the retroarch.cfg to this:
    input_enable_hotkey_btn = f
    input_exit_emulator_btn = g

    The arcade buttons start and select are routed to those keyboard inputs.

    When I tried pressing Start and Select simuntaniously, nothing happend. Escape button still worked though.

    What do you think I might have done wrong?

    #82244
    Profile photo of proxycell
    proxycell
    Participant

    i think you should use the button #. would you happen to know what those are for start and select?

    #82249
    Profile photo of RetroMarine
    RetroMarine
    Participant

    Yeah I would try using input_enable_hotkey = kp_f If that doesn’t work try to find the actual number value of that key

    #82280
    Profile photo of Floob
    Floob
    Member

    If you are using retroarch, you set the hotkeys as above.

    If you are talking about MAME, you can set it within the gui here:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #82308
    Profile photo of proxycell
    proxycell
    Participant

    is there a way to do this in osmose (game gear)?

    #82390
    Profile photo of escher
    escher
    Participant

    I’ve been throug the same problem. I’m building an Arcade machine and using the Zero Delay USB encoder.

    I’ve managed to get the exit btn working by adding the hotkey and exit_btn params in the SNES config file!

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar