PSX full screen, PSX Shaders, ROM compatibility and controllers

Welcome Page Forums RetroPie Project Video Output on RetroPie PSX full screen, PSX Shaders, ROM compatibility and controllers

This topic contains 14 replies, has 4 voices, and was last updated by Profile photo of resboyintl resboyintl 2 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #93598
    Profile photo of j2k15
    j2k15
    Participant

    Hi There,

    First of all, I’d like to thank you for all the precious information available on this website.

    Thanks to this, I’ve already been able to:

    – Install the RetroPie image on my Raspberry Pi 2
    – Configure my PS3-like (now autodetected) controllers in every RetroArch emulator.

    My material is:
    – A Raspberry Pi 2
    – HDMI and RJ45 cables
    – A 8 GB class-10 µSD card

    In order to make it more fun, I bought here and there several types of controllers depending on the system I want to play with.

    – 2 wired BigBen controllers PS3-like
    http://i11.twenga.com/jeux-video/manette-ps3/bigben-interactive-wired-controller-tp_359060270709389703f.jpg
    – 2 wired controllers SNES-like
    http://www.dropship-uk.co.uk/ekmps/shops/tddropship/images/usb-pc-retro-gaming-controller-joypad-snes-style-pad-black-4463-p.jpg
    – 2 wired controllers NES-like
    http://cdn1.coolstuff.com/autogen/preset/aspectThumb/1200×900/9f6a2066b1eb80cbf26ed06a154bacf0.jpg
    – 2 wired controllers N64-like
    http://ecx.images-amazon.com/images/I/4128BT2KojL._SX300_.jpg
    – A USB keyboard

    My open points are the following:

    – When I play a PSX game, the game is launched in a kind of window/frame. This window/frame fits more or less the size of my TV. The problem is that within the frame, the game is slightly zoomed which makes the image being cropped. The problem was specific to CTR. When I start another game before, and then CTR, the image is not cropped anymore. Strange but working workaround. 🙂

    – For PSX, I’ve another issue: the graphics are not so good. Reason is that by default no shader is used. My questions are: 1) will using a shader on a Pi2 prevent a full speed emulation for PSX ? 2) which one are you using ? always the same for each game ? solved by setting “smooth_video” parameter to true in the “all” retroarch.cfg file.

    – I saw that the RetroArch emulator for SNES is PocketSnes. With this emulator, I have some compatibility issues (display glitches, …) with some Roms (e.g. DBZ Super Butoden 2 in FR – I precise I use the good rom, the one with the ‘!’ in the filename). In Snes9x the rom plays nicely. So you can (and should 😉 ) tell me: “then use Snes9x”. The issue is that Snes9x does not seem to use the configs defined in file “UsbGamepad.cfg”. So my question is : within PocketSnes, are there some settings that would help getting a better emulation ?

    – For N64, I also use the RetroArch emulator in order to get benefit from all the standards (UsbGamepad.cfg). The problem is that Mario Kart M3 (E) ! rom is a mess on that emulator. Even the “press start screen” is buggy. Again, are there some settings that would enhabce the emulation ? I hope so because I never read elsewhere that someone had such an issue with that rom. FYI, this rom plays nicely on other emulators and on other platforms also.

    As you can read, I’m trying to use RetroArch as much as I can in order to have standard configs for all my emulators, … And I hope that some of you have succeeded in configuring their RetroPie like this so you can give me some advises.

    Have a wonderful weekend,
    Regards.

    J.

    #93699
    Profile photo of j2k15
    j2k15
    Participant

    Dears,

    About the PSX full screen issue, I might have found something.
    I was just playing CTR-PAL on my Mac (PCSX-R) and got the same issue (zoom in the window resulting in a cropped image).

    I changed one of the parameter (untick “fast boot”) and it solved the issue on the Mac.

    I’ll see if there’s a similar option on the Rpi and give it a try.

    I’ll post the result here.

    #93745
    Profile photo of j2k15
    j2k15
    Participant

    Dears,

    Now on the Mac I’ve been able to run the game with no cropped image and with fast boot.

    The problem seemed to be really specific to CTR. To solve it, I just started another game, close it, and then start CTR and by miracle no cropped image anymore !

    Strange, but working.

    So this part of the thread is solved.

    #93840
    Profile photo of j2k15
    j2k15
    Participant

    Dears,

    My graphics PSX emulation has been solved by updating the value of the parameter vidéo_smooth on the general config file (……/all/retropie.conf). Originally value was set to false and I moved it to true.

    Like this I don’t need to use shaders or the enhanced resolution option decreasing the perf.

    #94296
    Profile photo of resboyintl
    resboyintl
    Participant

    Any resolution to this? I am having issues with graphics. I have the video_smooth = True but still am getting lousy graphics. Granted, I have only tried Final Fantasy IX

    See images below.

    Capture from RetroPie 3.0 on RPI 2

    Actual PSX capture

    #94477
    Profile photo of gizmo98
    gizmo98
    Participant

    Actually it looked like your captured picture on a CRT. Ok. there is also a high res core option for PCSX_Rearmed. Open RGUI and select “Options/Core Options”. There is a performance drop if you enable this option.

    #94565
    Profile photo of resboyintl
    resboyintl
    Participant

    Thank you for the reply. I checked in the RGUI and went through the options you listed, however, it seems there are no cores in there. Can you provide additional information?

    Also What do you mean by CRT? Like an old CRT monitor? I took the picture with my phone using a 24″ HDTV. The “scan lines” is because of my phone. I am more trying to fix the horrendous rendering on the characters

    thank you!

    #94741
    Profile photo of j2k15
    j2k15
    Participant

    Hi,

    On a CRT, the graphics are perfect.

    A solution if you want to use a LCD screen might be to use a upscaling box.

    Like this one:

    http://retrorgb.com/upscalers.html

    #94848
    Profile photo of resboyintl
    resboyintl
    Participant

    Hi,

    On a CRT, the graphics are perfect.

    A solution if you want to use a LCD screen might be to use a upscaling box.

    Like this one:

    http://retrorgb.com/upscalers.html

    Ok, so I don’t see how this makes any sense, so maybe you can explain this to me…

    The Rpi is HDMI, so I couldn’t possibly use a CRT monitor without an adapter (and I don’t have a CRT monitor, anyway.)

    I don’t see how I would benefit from a device that “upscales”.

    Other emulator graphics, like snes, nes, and genesis have the appropriate graphics. I encounter issues with PSX, where the actual characters of the game are a pixelated mess. Also, the N64 has some graphical issues, where it doesn’t render some of the background (haven’t tinkered with that yet)

    Thanks in advance

    #95098
    Profile photo of j2k15
    j2k15
    Participant

    SNES with default shaders is quite crappy on my HDTV.

    NES however is OK.

    By default PS1 has no shader and on a HD TV the image is horrible.

    Playing on a CRT solves everything.

    If you don’t have one, there are some boxes like this to improve image quality:

    http://m.youtube.com/watch?v=pmTzP6izlrw

    Maybe it’d do the trick…

    #95227
    Profile photo of puck6t9
    puck6t9
    Participant

    – For N64, I also use the RetroArch emulator in order to get benefit from all the standards (UsbGamepad.cfg). The problem is that Mario Kart M3 (E) ! rom is a mess on that emulator. Even the “press start screen” is buggy. Again, are there some settings that would enhabce the emulation ? I hope so because I never read elsewhere that someone had such an issue with that rom. FYI, this rom plays nicely on other emulators and on other platforms also.

    useing the expermintal mupen64plus package fixed that for me. Also if you will just add your controler to the autoinputconfig.ini in the configs/n64 folder it will see your game pad and remap it (with out using retrorarch i understand but it worked better.)

    #95255
    Profile photo of resboyintl
    resboyintl
    Participant

    SNES with default shaders is quite crappy on my HDTV.

    NES however is OK.

    By default PS1 has no shader and on a HD TV the image is horrible.

    Playing on a CRT solves everything.

    If you don’t have one, there are some boxes like this to improve image quality:

    http://m.youtube.com/watch?v=pmTzP6izlrw

    Maybe it’d do the trick…

    Ok, I’m still at the point where an upscale device is not going to fix this issue, and this is not an issue vs CRT/HDTV

    Here are some images of each emulator. (trying to take better photos, since I don’t know how to perform a screen capture, and can’t find info about it)

    Genesis/Megadrive (Shining Force 2)

    NES (Teenage Mutant Ninja Turtles)

    SNES (Super Mario 3- All Stars)

    PSX (Final Fantasy 9)

    Someone mentioned a “High Res Core” in PSX, but when I navigate there, there is no core loaded. I’ve tried searching for cores/shaders and am unable to find any, it seems. The graphics look great in all the other emulators I have loaded, except PSX.

    I tried playing final fantasy 9, and the characters in game are terribly pixelated, as were the surroundings, until I turned on the smoothing, but it did not fix the character rendering.

    Are there settings I can adjust in RetroArch config? Or the emulator config? Where does the high res core come from? I’d like to try it, but it’s not on the image.

    #95257
    Profile photo of j2k15
    j2k15
    Participant

    Thanks puck6t9.
    I’ll follow your recommendation posted here :

    N64 problems…

    #95260
    Profile photo of j2k15
    j2k15
    Participant

    It’s in fact an option not a shader.

    Go in Retroarch Menu of PSX emulator and then choose Core Options.

    You’ll find an option to get higher resolution but performance will drop a lot.

    Btw, you are able to control Mario in Super Mario all stars ?? I tought it was not possible to run (control Mario in-game) this one in Retroarch…

    Btw 2, your graphics seem so great for Snes ! Far better than mine if I’m plugged on HDTV.

    #95265
    Profile photo of resboyintl
    resboyintl
    Participant

    I can control Mario just fine in the game. didn’t have issues with Allstars at all. At least not super mario 3

    I don’t see anything that indicates a core in the menu. I don’t see how to select one:

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar