PSX emulation sloppy (lr-pcsx-rearmed vs pcsx-rearmed)

Welcome Page Forums RetroPie Project Video Output on RetroPie PSX emulation sloppy (lr-pcsx-rearmed vs pcsx-rearmed)

This topic contains 20 replies, has 7 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 10 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #104306
    Profile photo of haze303
    haze303
    Participant

    Hi guys,

    anyone noticed slow psx emulation with lr-pcsx-rearmed vs pcsx-rearmed from retropie_setup/experimental?

    pcsx-rearmed works properly so far but isn’t that good integrated in RetroArch therefore I would like to play with lr-pcsx-rearmed instead.

    I’ve tried several configs (switched video_driver, audio_driver etc. pp) in psx/retroarch.cfg but nothing really helps.

    Thanks for your input and cheers,
    haze303

    EDIT: I’m on RetroPie 3.0 Final with my RP2. Overclocked 1000/500/500/2 and my gpu split is 384. Temps are ~50-60°C on load.

    #104309
    Profile photo of lilbud
    lilbud
    Participant

    Runs fine on mine, I am running Retropie v3.0 Beta on the pi 2 fully overclocked, pi2 setting.

    #104392
    Profile photo of leiptrstormr
    leiptrstormr
    Participant

    Yes. The final 3.0 RetroPie lr-pcsx-rearmed audio is very poor. As far as I can tell the games are running full frame rate with the exception of a load here and there. Audio is just very choppy.

    #104407
    Profile photo of dankcushions
    dankcushions
    Participant

    as with all the libretro versions of emulators, you’ll find that they’re branches of the main emulator developments. I doubt that the libretro hooks add in much overhead, but the chances are high that because it doesn’t include the most current version of emulator, it runs worse as a result.

    that said, for this emulator I get almost perfect emulation with the libretro version (some very small hiccups in tekken 3). what’s happening for you? what games? perhaps your overclock is too aggressive.

    #104514
    Profile photo of haze303
    haze303
    Participant

    Are you using RetroPie 3.0 Final?

    I just tried to run WipeOut 2097 with the Pi 2 default clocks but unfortunately I got the same result. Choppy audio and like 20 fps.

    #104535
    Profile photo of dankcushions
    dankcushions
    Participant

    hmm, there are a few options that will reduce performance. perhaps one of these is mistakenly set in retropie 3.0 final? because i’m running an updated 3.0 beta 3 with retroarch 1.2.2 with lr-pcscx-rearmed r22 and my performance is fine.

    here’s a few things that might sort it

    hotkey (usually select) + triangle/Y to get to the RGUI

    quick menu > core options
    frameskip should be 0
    dynamic recompilier should be enabled
    interlacing should be disabled
    enhanced resolution should be disabled
    enhanced resolution should be disabled

    quick menu > shader options
    shader passes should be 0 (you can get away with some shaders with minimal performance impact, so if you know what you’re doing, go ahead!)

    settings > video
    HW Bilinear Filtering should be OFF (this turns off smoothing of the screen – has a performance impact)

    settings > driver
    input = udev
    joypad = udev
    video = gl
    audio = alsathread
    audio resampler = sinc

    if any of this works, post it here so we can get the relevant scripts updated 🙂

    #104536
    Profile photo of Floob
    Floob
    Member

    For reference, this is lr-pcsx-rearmed on a Pi 2 running standard overclock.

    I thought it ran pretty well, but maybe I didnt go into enough detail.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #104542
    Profile photo of Floob
    Floob
    Member

    Just gave it a go on vanilla RetroPie 3, all seems good, no choppy audio on WipeOut.

    Do you have a 5v 2a power supply – that can cause issues sometimes if its less than that.

    Also, if you load the game, go into RGUI and select save new config, it will create a “libretro.cfg” in your /opt/retropie/configs/psx/ directory.
    If you post that as an attachment or on pastebin I can compare it to the one I have to make sure it is the same.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #104556
    Profile photo of haze303
    haze303
    Participant

    Thank you for your help. I’ll try to check for dankcushions settings and if it’s not working then I’ll post my libretro.cfg.

    My power supply is a 5v 2A one.

    #104561
    Profile photo of haze303
    haze303
    Participant

    I tried to match dankcushions settings but none of them are available in the core options menu. The rest looks ok so far.

    I pasted my libretro.cfg to pastebin: http://pastebin.com/5Y9CaifW

    Hopefully you can help me find to odd setting…

    Thanks a lot!

    Edit: I even used a 1:1 (except the input_overlay* settings) copy of Floobs psx/retroarch.cfg like in the video but that didn’t help.

    #104589
    Profile photo of dankcushions
    dankcushions
    Participant

    hi haze303 – weird you don’t get the core options menu stuff! perhaps retropie 3.0 still doesn’t have retroarch 1.2? no matter, i’ve had a look at your cfg and have the following suggestions:

    video_threaded = “false” (change this to “true”)
    rewind_enable = “true” (change this to “false”)

    if this helps, please let me know 🙂

    #104606
    Profile photo of haze303
    haze303
    Participant

    I edited my psx/retroarch.cfg and just entered your two line suggestion and you know what? It working flawless!

    Thanks a lot guys. You’re awesome! 🙂

    #104632
    Profile photo of Floob
    Floob
    Member

    Glad you sorted it. 🙂

    For reference, the difference between your settings and the default are, you had:

    rewind_enable = “true”
    video_smooth = “false”
    video_shared_context = “true”
    Lots of custom button settings for player 1 and player 2

    Your settings imply you arent using RetroPie 3 final, as the smooth mode is off. Unless you manually changed that.

    Also, your settings saved show you already had video_threaded = “false”, so not sure why this in the psx retroarch would fix things.

    But if its changed for the better then its all good 🙂

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #104644
    Profile photo of dankcushions
    dankcushions
    Participant

    good news!

    floob, i said i think video_threaded should be true – my understanding that it puts the video process to a seperate thread, which is good for multicore systems like the pi2.

    i was curious so i just checked and i have it set in fba/mame and psx already. i don’t believe i ever changed it, so i’m thinking it must have changed in 3.0 final.

    https://github.com/RetroPie/RetroPie-Setup/blob/master/scriptmodules/emulators/retroarch.sh
    iniSet “video_threaded” “false”

    you can see that jools set it to false in this change: https://github.com/RetroPie/RetroPie-Setup/commit/f86c4b233efe1660ef5d9f0408d9f455607c4f32

    reasons are given – i’m not sure i’ve had any out of sync stuff (only in mupen64plus, which isn’t libretro anyway), but i can’t also be sure that it boosts performance noticably. it’s difficult to test given that none of the frame rate counters seem to work in libretro!

    #104650
    Profile photo of Floob
    Floob
    Member

    Yes, thats right, the default was changed in RetroPie 3.
    https://github.com/RetroPie/RetroPie-Setup/issues/933

    I dont seem to see much/any difference with it on or off for the PSX comparison, so I was a bit surprised that someone had an issue that was sorted by changing it.
    Perhaps its one for discussion.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #104652
    Profile photo of dankcushions
    dankcushions
    Participant

    my guess is that the rewind_enable setting killed their performance more than anything else – I think that basically buffers the last few moments of gameplay (by memory dumps?) so you can reverse. I imagine it kills the poor pi(2)

    #104653
    Profile photo of haze303
    haze303
    Participant

    I do think the rewind_enable = “false” had also a big impact as the buffer will be constantly overwritten which causes alot of IO on the sdcard. Maybe too much for the PSX emulation to be smooth and “rewindable” at the same time.

    I just did some tests with the N64 emulator which also wasn’t that smooth and is infact now pretty smooth with rewind_enabled = “false”.

    EDIT: dankcushions – hivemind… 🙂

    #104711
    Profile photo of tgilly
    tgilly
    Participant

    I noticed the rewind_enable = “false” is actually configured as such in the general retroarch.cfg (RetroPie 3.0 final) so configuring it specific for PSX or N64 is obsolete right ?

    #104717
    Profile photo of petrockblog
    petrockblog
    Keymaster

    if it’s set to false in the main retroarch.cfg there is no point setting it to false in per system configs correct. rewind is disabled by default.

    The video_threaded option may help with performance for some emulators that barely run full speed etc – it can easily be switched on and off without any file editing by using the config editor from the supplementary menu.

    #104721
    Profile photo of dankcushions
    dankcushions
    Participant

    doesn’t that conflict with the OP’s situation, though? there’s was set to enable rewind in the psx config (perhaps by accident but even so), and by reverting it they corrected the issue. so the individual core configs override the /all/retroarch.cfg?

    if that’s the case I’m not entirely sure of the purpose of the all/ one!

    video_threaded is set to false in all/retroarch.cfg (as of 3.0 final), so you could override that if my assumptions about overrides are correct. I’ve got an older version so it’s set to true. all my emulators work fine as far as I can tell.

    #104725
    Profile photo of petrockblog
    petrockblog
    Keymaster

    If they had set it to rewind in the psx config (and it was above the include line) it would have overwritten the all/retroarch.cfg default. the per system configs are designed by default to override all/retroarch.cfg

    if anyone doesn’t like video_threaded set to false, they can either enable it globally or on a per system basis.

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar