PS4 Wireless Controller?

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of danky danky 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #111830
    Profile photo of wmtravisp
    wmtravisp
    Participant

    Hi all, apologize if this is a repeat but I haven’t found like topics in the search.

    I see multiple tutorials for PS3 controllers and how to set them up for wireless use with retropie. Do the same instructions apply for a PS4 controller?

    I currently have my PS4 controller working well, but I’m using the cable. Before I go down this rabbit hole of attempting to set it up wirelessly, I was hoping someone might have a link or something to a video or article by someone who has done this.

    Why are all the tutorials for PS3 controllers? Is it because people have them laying around now that PS4 has been out awhile? Or is there some difference that makes the PS3 controller a better candidate for use with RetroPie?

    Thanks in advance for your time.

    #111878
    Profile photo of Berni-H3
    Berni-H3
    Participant

    Hi

    I’m using two PS4 controllers and some time ago i wrote here how i did it.

    Link

    I hope this will help you if not feel free to ask any question you have.

    #115706
    Profile photo of danky
    danky
    Participant

    I know this is a little over a month old but I followed your steps Berni…

    I followed the steps and saw this:

    pi@retropie ~ $ hcitool scan
    Scanning ...
            0C:EE:E6:FD:6D:EA       Wireless Controller
    pi@retropie ~ $ sudo l2ping -c 1 0C:EE:E6:FD:6D:EA
    Ping: 0C:EE:E6:FD:6D:EA from 5C:F3:70:75:98:C5 (data size 44) ...
    52 bytes from 0C:EE:E6:FD:6D:EA id 0 time 5.92ms
    1 sent, 1 received, 0% loss
    
    pi@retropie ~ $ sudo bluez-simple-agent hci0 0C:EE:E6:FD:6D:EA
    Release
    New device (/org/bluez/5704/hci0/dev_0C_EE_E6_FD_6D_EA)
    pi@retropie ~ $ sudo bluez-test-device trusted 0C:EE:E6:FD:6D:EA yes

    Then the controller was lit up instead of blinking. So I rebooted, started up emulation station, and controller didn’t work. It kept blinking as if it was trying to pair.

    #115709
    Profile photo of danky
    danky
    Participant

    Actually. I’m going through your setup again and I just realized, bluetooth isn’t even work. I’m not sure why it suddenly stopped after reboot. Any ideas?

    pi@retropie ~ $ /etc/init.d/bluetooth status
    [FAIL] bluetooth is not running ... failed!
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar