PS4 Controller – PCSX-ReARMed

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie PS4 Controller – PCSX-ReARMed

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of jmaxime89 jmaxime89 1 year, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #113493
    Profile photo of cgorms
    cgorms
    Participant

    PS4 controller setup and working with all RetroPie emulators apart from when I placed a PSX bios file in the bios for PCSX-ReARMed.

    When I launch the PCSX-ReARMed the game starts but the PS4 controller does not work, can any one help??

    I have not changed anything in the Retroarch.cfg file under PSX

    Sent from my iPhone using Tapatalk

    #113667
    Profile photo of jmaxime89
    jmaxime89
    Participant

    Excuse me, I really don’t want to hijack your thread. I already posted my question in my own thread but nobody is looking at it.

    I have a wired ps4 controller and I’m having a hard time trying to configure it with retroarch. It works fine in emulationstation however.

    In my retroarch autoconfig emulationstation and retroarch are naming the config file differently.

    If you are using a wired ps4 controller would you please send me your config files.

    Thanks a lot. I’ll try to see if my controller is working with the other emulators (maybe we have the same problem, usually I use my snes controller for everything except PSX)

    #113669
    Profile photo of jmaxime89
    jmaxime89
    Participant

    Sorry double post

    #113746
    Profile photo of deadward
    deadward
    Participant

    To quote Floob:

    If your PS3 controller says its not configured in yellow text at the bottom of the screen, it may be that you need to change this line in /opt/retropie/configs/all/retroarch.cfg

    input_joypad_driver = udev

    Then re-configure the PS3 controller in Emulation Station.

    And I know this says ps3 controller but I was having the same exact issue when using a ps4 controller and chaning the driver fixed the issue for both ps3 and ps4 controller. You can also get to this setting and change it through the RGUI.

    To use the RGUI to change it:
    RetroPie
    EDIT RETROPIE/RETROARCH CONFIGURATIONS
    1 Change common RetroArch options
    0 all/retroarch.cfg
    13 input_joypad_driver (udev)

    New technology doesn't solve all our issues, it changes the issues we have.

    #113760
    Profile photo of jmaxime89
    jmaxime89
    Participant

    Thanks a lot ! I’ll look into that when I get home.

    However when I start a game it says in yellow : PS4 controller slot #0 or something like this.

    I also try to map it in retroarch in the retropie menu.

    I’ll follow your instructions carefully and report.

    Thanks again

    #113981
    Profile photo of jmaxime89
    jmaxime89
    Participant

    You, Sir, are my hero ! It totally works. I can’t believe I didn’t find that info by myself.

    After I set it to udev I mapped with emulationstation, mapped it again with retroarch and bingo! It worked.

    Thanks once again !!!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar