PS3 pad an mame

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of gilera gilera 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #91142
    Profile photo of drokkster
    drokkster
    Participant

    Hi all

    How do you configure controls for the mame emulator on retropie. 2.6 using a PS3 pad?

    The emaulator loads fine but once a game starts you have no way of controlling it. Is this still the bug with mame4all and the ps3 pad?

    #91143
    Profile photo of davejaca
    davejaca
    Participant

    Hi, I just tried this out and everything works fine. Press tab to bring up the config menu and you can go through and set up your buttons. I haven’t set up anything special or edited any config files with my Mame emu because I dont use it very often, it just works.

    Did you make sure to run the built in joypad setup in retropie_setup.sh?

    #91144
    Profile photo of drokkster
    drokkster
    Participant

    Hi yes i did. just to confirm PSX, N64, NES, SNES etc all work ‘out of the box’

    I seems the mame bindings needs to be configured then by using TAB?

    #91148
    Profile photo of drokkster
    drokkster
    Participant

    Thanks Dave. Will give it a try when home from work and report back to confirm working.

    #91530
    Profile photo of gilera
    gilera
    Participant

    I don’t want to hijack the thread but i do have the same issue, all other emulators seem to work OK (including mame-libretro) but mame (mame4all) doesn’t.

    I notice in the emulationstation es_systems.cfg file that mame4all gets started without specifying the retroarch.cfg file.

    In the same file mame-libretro is started with the retroarch.cfg and my pad works as expected but i have other issues with mame-libretro so would like to use mame4all.

    I’ve tried using the keyboard, TAB, ESC etc but nothing works, i started the mame4all emulator from cli without loading a rom and controls don’t work on the front-end menu and neither does the keyboard.

    Any ideas?

    PS. Oh and thanks for this amazing setup-script I’ve had so much fun these past few days.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar