PS3 Mad Catz Wired Stick 8818 weird behaviour

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie PS3 Mad Catz Wired Stick 8818 weird behaviour

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of drzero drzero 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #96880
    Profile photo of ataloss
    ataloss
    Participant

    Hi,

    I’m having a really strange intermittent issue with my PS3 MadCatz USB Wired Stick 8818. Sometimes, about one in 30 boots it works, and works until I reboot otherwise it is detected but doesn’t work.

    On bootup it is detected as MadCatz PC USB Wired Stick 8818.

    lsusb shows the following:
    Bus 001 Device 004: ID 0738:8818 Mad Catz, Inc. Street Fighter IV Arcade FightStick (PS3)

    Even when it isn’t working and I run jstest /dev/input/js0 it is detected and shown on screen but when you move the stick, and press the buttons nothing happens. Obviously on that 1 in 30 times when it does work when everything is okay in the jstest.

    It is detected in emulationstation, but you can’t configure it.

    I plugged it in via a powered usb hub in case it was a ‘lack of power’ issue. I also tried another raspberry pi, and I’ve got 2 controllers and both have the same issue.

    I can’t work out what makes it work on that 1 in 30 times. Perhaps it has something to installing the PS3 controller drives via the retropie menu, but even so, it won’t then work immediately, or on the same boot, but later…then it stops again.

    Has anyone experienced this, or could anyone help me track down the issue.

    Thank you

    #97403
    Profile photo of ataloss
    ataloss
    Participant

    does anyone have an idea about this? is it a general ps3 wired controller issue?

    #100123
    Profile photo of greensnake
    greensnake
    Participant

    Hi,
    I’ve got the same issue with same controller.

    I seen a post of someone said that this controller as issue with linux, and he has wired it on raspberry GPio instead

    Another one (on Windows 7) said that it is an issue with USB 1.1 controler
    He bought an old usb 1.1 controller to make it work on Windows.

    I have tested with an ordinary hub, I was lucky that the 1st time I plug it was working but after same issue, I had to plug and unplug 10 times to make it work.
    I guess with testing with some others hub more expensive (and more flexible with usb1.1) it can work better but I haven’t got any other hub to test with.

    Let me know if you find somethig out
    Thanks

    #107973
    Profile photo of drzero
    drzero
    Participant

    I’ve also got issues with the Mad Catz SFIV Arcade Stick (identified as MadCatz PC USB Wired Stick 8818 by jstest). If I connect it to my Ubuntu 14.04 desktop and use jstest, all buttons work fine. When I connect it to my raspberry pi 2 with either raspbian wheezy or retropie 3.1, none of the buttons react in jstest. It is detected fine, and /dev/input/js0 is available, but none of the buttons work. Anybody got an idea what is wrong?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar