PS3 Controller not recognized (even through USB)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie PS3 Controller not recognized (even through USB)

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of tendonut tendonut 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #96357
    Profile photo of kirin
    kirin
    Participant

    Hello everyone!

    I’m quite new to RPi, and recently bought myself an RPi 2. So, I decided to use it as old-school gaming station together with my Dualshock-PS3 controller (official sony, no 3rd party).
    I followed the guide on the github exactly ( https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-a-PS3-controller ), but my problem is, that the Pi doesn’t recognize the controller even if it is connected via USB. Aka, the js0 file is not written in /dev/input.

    Any idea what I could do?
    Could something be wrong with my setup/sd-card? Because, when I close Kodi (have it installed through the retroPi-Script), sometimes the Pi just freezes, and after hard resetting (power off/on) I get an “bad read/write IO error” or something like that, which keeps the pi in a bootloop, until I power if off & on again.

    Thanks & Greetings
    Kirin

    EDIT: I just checked lsusb – there it is connected & in the dmesg it is also found & initialized.

    #96360
    Profile photo of kirin
    kirin
    Participant

    So, the problem just solved itself – I just restarted the Pi after restarting sixad – and voilá it worked like a charm.

    If someone on the internet someday has a similiar problem, I think the following steps might help:

    1. Follow the installation-guide in the wiki up to the point where you pair with sixpair – just pair the controller.
    2. Then, just use the following commands:
    sudo sixad --stop
    First stop sixad if it was running somehow.
    sudo sixad --boot-yes
    Then put sixad in the startup
    sudo reboot
    Finally reboot the pi.

    Best case: You just got your PS3 controller working via bluetooth. 🙂

    #96365
    Profile photo of tendonut
    tendonut
    Participant

    You can probably skip step 2. Shutdown stops the service as well. But yeah, the built in PS3 pairing system doesn’t really seem to work.

    It appears as if the service doesn’t get added to the boot process automatically unless the PS3 pairing script finishes successfully (which I’ve never gotten it to do). So once you install the PS3 drivers, then plug in the controller and run..

    sudo /opt/retropie/supplementary/ps3controller/sixpair

    and get the two MAC addresses to match, confirming the top MAC address (the controller) matches the bottom MAC address (your Bluetooth Dongle), you can then go ahead and add the sixad daemon to the startup sequence.

    sudo sixad --boot-yes

    Unplug the USB cable, give the Pi a reboot, and it should sync up after it boots up when you hit the PS button.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar