PS3 controller does not work in game, but does in UI?

Home Forums RetroPie Project Controller Configuration in RetroPie PS3 controller does not work in game, but does in UI?

This topic contains 19 replies, has 14 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 5 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #112567
    Profile photo of bmeowmix
    bmeowmix
    Participant

    Just tried setting up Retropie for the first time and got most things running, but when I use my PS3 controller in game it does not work. I can use it fine in the UI, selecting games, accessing menus, etc. but when I go into a game it quickly flashes “PS3 Controller (1356/616) not configured”. Keyboard works fine. Any ideas on whats wrong?

    #112599
    Profile photo of thibbs
    thibbs
    Participant

    I am also experiencing this issue, have you had any luck since posting this?

    #112637
    Profile photo of pheonix303
    pheonix303
    Participant

    I have had the same issue. I thought that i commented twice last night on this post but i checked this morning and my replies were not there so i am posting this one. My solution is only a temporary fix so if anyone has a better and permanent solution please share. I did this last night so i might be a little confusing. If you need clearer instructions i can set up my controller again and write down the exact steps to post on here. The first thing i did was launch a game, in this case it was Super Mario World on the SNES emulator. I had the same error message as you did, “PS3 Controller (1356/616) not configured”. To fix this i used my keyboard pressed F1 to bring up the menu and then i went to settings. For me to continue was to press ‘x’ and to go back was to press ‘z’.From settings i went to driver and made sure that the input driver and the joy pad driver were both set to udev. Then i went back to the first settings page and then down to video and selected full screen. When i say selected it i mean that i pressed the button to choose it, i did not press the arrow keys to turn it on or off, from what i can tell it does not matter if you keep it on or off as long as you press ‘x’ while highlighting the full screen option. Doing this i would get a yellow message in the bottom left of my screen saying that my controller is configured. i then resumed the game. this caused only my PS3 controller to work and not my keyboard but it did seem i had hotkeys on my controller. When i hold down the button i set as select, which in my case was the select button, and then press another button. in my case i pressed select and square, my square was set to ‘x’ for the game pad. This opened another prompt in which i was able to navigate and find something labeled as analog to joy pad driver, you could probably have done this step before you resumed the game. Once i found that i set it to the left analog and this allowed me to use my left analog in game. Again if you want me to have clearly instructions i can run through it again myself this time writing down the steps. Also if anyone else has a better and permanent solution please share.

    #112691
    Profile photo of rgelb
    rgelb
    Participant

    @pheonix303 Somehow I am not able to save the changes that I am making in the F1 menu. Following your instructions, I went into the Settings/Driver, the input driver was already ‘udev’. I then changed the joypad driver to ‘udev’ as well. I went up a level, selected Video, scrolled down to Full Screen option, pressed X and, as you predicted, I got a yellow message stating that the controller was configured. I then went up a level, selected last menu item (‘Quit RetroArch’, I think), went back into the game and still got the “PS3 Controller (1356/616) not configured”.

    I went back into the F1 menu and the joypad driver was NOT ‘udev’. So I repeated the procedure, except this time I also pressed ‘Save Current Config’ and exited the settings via the ‘Quit RetroArch’ menu. And still, i got the “not configured” message in my NES game.

    Sounds like you were actually able to persist/save the settings somehow. Would you mind describing exactly how you did it?

    #112696
    Profile photo of gizmo98
    gizmo98
    Participant

    Go to RetroPie-Menu (in emulationstation) and select “Edit RetroPie/RetroArch configurations”. Select option “1 Change common retroarch options” and select “all”. Set “input_joypad_driver” “udev”.

    #112716
    Profile photo of pheonix303
    pheonix303
    Participant

    @rgelb I forgot to mention you need to the quick menu and resume game not quit. But gizmo98’s solution works a lot better.

    #112717
    Profile photo of rgelb
    rgelb
    Participant

    Awesome, thank you all. @gizmo98‘s answer actually did the trick.

    #113094
    Profile photo of sealy-au
    sealy-au
    Participant

    Thanks a bunch gizmo.
    just wish it didn’t take me 3 hours to find this thread…. FML

    ps3 controller not configured

    #113167
    Profile photo of seanboyu2
    seanboyu2
    Participant

    thanks gizmo98

    #113214
    Profile photo of strmbwl
    strmbwl
    Participant

    A big thank you to @gizmo98 was stuck all last night trying to figure out why it wasnt working!

    #113566
    Profile photo of peterheater
    peterheater
    Participant

    Can anyone clarify how you save these settings after you set them? This can be done through the GUI? Thanks!

    #113697
    Profile photo of youdoofus
    youdoofus
    Participant

    im having the same issue. im going to reload the image tonight to see if that helps, and f1 while emulating doesnt do anything for me

    #113752
    Profile photo of deadward
    deadward
    Participant

    im having the same issue. im going to reload the image tonight to see if that helps, and f1 while emulating doesnt do anything for me

    youdoofus(not calling you names… just addressing you. 😛 ), I don’t think reloading the image is necessary. I noticed that my input_joypad_driver seemed to change when I went updated, udev in 3.2 to sd12 3.3. I tried updating via the screens and “U Update RetroPie-Setup script” but ran into an issue and had to start fresh with a new image. When I loaded my new image and started playing around. I realized my ps3 controller was no longer working for games but was working for emulationstation. I am not sure if maybe the default changed between versions. But as Gizmo89 said:

    Go to RetroPie-Menu (in emulationstation) and select “Edit RetroPie/RetroArch configurations”. Select option “1 Change common retroarch options” and select “all”. Set “input_joypad_driver” “udev”.

    And this will fix your problem. Remember you have to reconfigure your controller again after you make the change.

    New technology doesn't solve all our issues, it changes the issues we have.

    #113798
    Profile photo of youdoofus
    youdoofus
    Participant

    Thanks for your reply!!! I did all that you had mentioned on the previous image to no avail (been reading the forums for quite a while and am pretty adept in android modding). I reloaded the image and repeated the steps and it worked flawlessly after completing the Select option “1 Change common retroarch options” and select “all”. Set “input_joypad_driver” “udev” portion 😀

    #113836
    Profile photo of youdoofus
    youdoofus
    Participant

    the retro gaming goodness is now abundant!! 😀

    #114068
    Profile photo of catrinisin
    catrinisin
    Participant

    I have the same issue but these steps are not helping for me. My input_joypad_driver in the all/retroarch.cfg is set to udev now. I;ve rebooted and reconfigured the controller in emulationstation but still nothing when I launch any game in any emulator.

    I am running 3.3. that I upgraded from 3.2.1 using the binary install option.

    #114093
    Profile photo of gordonmorgan
    gordonmorgan
    Participant

    I am having the same issue but not with all emulators. I changed the input_joypad_driver to udev after the initial set up etc, and this has got the PS3 controller working in the main menu and SNES and NES emulators but I cannot get it to work under MAME. When I checked the settings for MAME the driver was still UNSET so I changed it and it now shows udev but even after reconfiguring the controller and rebooting the device it still does not work. Any ideas?

    * edit this is on 3.3.1 btw

    #114106
    Profile photo of catrinisin
    catrinisin
    Participant

    Update: My xbox 360 controller has the same issue. No emulators work, but the UI does. Arg

    #114122
    Profile photo of catrinisin
    catrinisin
    Participant

    So as a test I used a spare sdcard and loaded a fresh image of 3.3 as well as trying 3.2.1. In both versions I have the same exact issue, controller works in the UI and not in any games. Both PS3 and xbox controller. I at a loss at this point.

    #114129
    Profile photo of herbfargus
    herbfargus
    Member

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar