PS3 Controller (Bluetooth) – Analogues don't work.

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project PS3 Controller (Bluetooth) – Analogues don't work.

This topic contains 3 replies, has 3 voices, and was last updated by  killer101 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #81932


    Hi, I am using the latest RetroPie and I can use my PS3 controller over BT, but the analogue sticks don’t work. So I can only play with the D-Pad.
    I searched a lot of forums, but most of the guides refer to the old version of RetroPie, so no help there.
    Do I need to edit the retroarch file? Can someone send me their config that works with this controller please?

    Thank you

    EDIT: I tried to play Doom in ‘Ports’ and when I exit the game, the Retroarch config screen comes up, and it allows me to bind the analogue, but it doesn’t save it.



    Hello my friend!

    I had this same problem, now solved.
    Try add this line
    input_player1_analog_dpad_mode = “1”
    the end of line /opt/retropie/configs/all/retroarch.cfg



    Thanks for the tip. Will try as soon as I download v2.5 🙂 (It’s very slow 🙁 )



    Go to

    Edit all PS3-Controller related config files and add the following lines:

    input_up_axis = “-1″
    input_down_axis = “+1″
    input_left_axis = “-0″
    input_right_axis = “+0″

    Then the left analog stick works like the D-Pad!

    Have fun!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss