PS3 bluetooth controller, correct method for retropie 2.3?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project PS3 bluetooth controller, correct method for retropie 2.3?


This topic contains 13 replies, has 5 voices, and was last updated by  doanerock 3 years ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #47718


    What is the correct way to link PS3 Bluetooth controller to a Bluetooth adapter in the retropie. I have set up the PS3 controller with retrope with a before 2 retropie. Are there new instructions? What is the current correct way to pair the controller with the retropie?




    I ve managed to do it without updating the retropie setup script..



    So you just use the set up ps3 script. I have tried it in the previous 2.x retropie versions with unsuccessful results. I would appreciate a short video showing how you set up the ps3 from start to finish. Does your ps3 controllers do what I liked to the the happy shake, which is once it paired with the retropie it runs the rumble.





    Ok I followed the instructions above, and the controllers pair with the retropie, I follow the instructions to “Hold a button on your device to configure it” and I do, but asks me to configure it EVERY time I reboot. I also added the es_input.cfg commands from
    so that I could use all the buttons and they where mapped properly.

    What else do I have to do to make the controller work properly?



    Why can I not use the gamepad if it detects the gamepad? I don’t want to configure it each time I start emulation station.



    Doanerock this is a known “bug” i suppose.. I am facing the same problem every time i reboot my retropie image. I think it is smth with the bt connection-drivers though..



    Well I can’t even play the games because I need to program the rest of the buttons like your are instructed in the how to.
    Plus I am not able to exit any games because that has not been programed yet.

    Is there any work around until the BUG is fixed?



    The newest Retropie-Setup-Script contains auto config files for PS3 controllers so your controller should work out of the box. The dhomium3009 guide is out of date regards this.

    You can find the mappings for PS3 bluetooth controller at

    The file should be in your /home/pi/RetroPie-Setup/supplementary/RetroArchConfigs folder on your pi.

    To exit a game, you need to press SELECT and START at the same time.



    dudleydes I tried that. I reformatted the SD card with retropie 2.3 on it and used ./RetroPie-Setup/ and ran “313 Install PS3 controller driver” and followed the directions. I followed the directions and connected the PS3 controller via USB and retropie sad that one controller was connected. Then I rebooted it and tried to pair it up with the PS button, but it never connected via blue tooth.



    so I just reinstalled retropie 2.3 and the ps3 controller would not pair with retropie. The only way I can get the ps3 controller to pair with the retropie is with these instructions “” but I am not able to play because it makes me redo the controls each time.



    I too was having the same issue with EmulationStation prompting to re-configure the controller (ps3) bindings every time on reboot, also many times the controller would not even be detected.

    I finally have my PS3 controller working consistently. It turns out there was a two-year old comment on this very blog that hinted at the the solution. What’s happening is that EmulationStation is starting up too quickly — not allowing enough time for the PS3 controller to sync over bluetooth and setting itself up as a joystick.

    The fix:

    1. Start the retroie-setup script and disable the splash screen (there’s an option for this)

    2. Edit the /etc/rc.local file with your favorite editor:

    Above the “exit 0” statement enter the following:

    echo "Sleeping for 30s.  Sync your controller now..."
    sleep 30s

    Now every time you boot the Pi, it will notify you to sync your PS3 controller (simply press the PS button on the controller), then EmulationStation will start thereafter.

    On a side note, RetroPie 2.3 has a built-in controller profile for the PS3 controller — meaning you do not have to manually map buttons in RetroArch. The “hotkey” by default is the SELECT button. So SELECT+START exits, SELECT+L loads last save, etc.



    The above didn’t work for me, still asks me to configure controller buttons, doesn’t prompt me to sync controller 🙁

    Kent - UK



    d3s1, your suggestion worked great. All I did was,
    copy the retroPie image to the SD card.
    Expand the file system
    update retroPie operating system (probably not necessary but I like to update)
    follow d3s1 instructions above
    use menu to install PS3 drivers.

    So only issue I have is that normally when you press the PS button on the controllers(I am able to pair and use two) it will blink all four until it pairs, and then only one light corresponding to the controller number will stay light. The issue is now that the controllers four lights never stop blinking. Everything in retroPie works great but having all four lights on the controller constantly blinking is a bit distracting and you do not know which controller is controller one and which one is controller two.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss