Problems with Turn on/off and with controls

Welcome Page Forums RetroPie Project GPIO Adapter, ControlBlock etc. Problems with Turn on/off and with controls

This topic contains 8 replies, has 3 voices, and was last updated by Profile photo of petrockblog petrockblog 2 years, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #97766
    Profile photo of MarcoCol
    MarcoCol
    Participant

    Hi,

    I use the RPi2 and I have two big problems:
    1) Turning on/off:
    The ControlBlock is very cool, but something didin’t work:
    I’ve installed everything and it might seem to be ok.
    So I connect the USB-to power. Then I switch my switch to ON.
    The LED fades a lot of times and I see on the screen, that RetroPi is booting. Good
    After successful loading I switch to OFF and the RetroPi shutdown. Cool! 🙂 – until here!
    When I then try to switch to ON again, the LED fades slow, but I didn’t see anything on the screen. Same when I try again switch to OFF (it fades then only too!)!
    When I disconnect the power of the USB and connect it again, then it works again as written above.
    I use that switch:
    http://www.arcadeshop.de/Accessoires-Wippschalter-SDW-5A-grün_924.html
    And I use a 2x USB power suply whiuch has 1000mA on port 1 and 2100mA on port2. I use port2.
    I attach an image!

    2) After the ES is loaded my connected buttons/stick doesn’t work.
    I install Mame stick and pushbuttons, I also connect the ground.
    Before I install ControlBlock I have connected the IPac2 and it works with changes in “retroarch.cfg” – now I turn that changes into the standard values how they are after a clean installation. But it didn’t work.
    I didn’t also know where to connect the buttons for “Pause” and “exit”?!

    Any idea?

    Attachments:
    #97811
    Profile photo of MarcoCol
    MarcoCol
    Participant

    Regarding 2:
    I remember that I must configure the keys in the ES-Config and then this works.
    But when I there config them I have keys which I don’t know how to set them.
    I have only that buttons:
    4 x 1P-Axis
    4 x 2P-Axis
    Button 1P 1-5
    Button 2P 1-5
    Player 1 Start
    Player 2 Start
    Pause (where must I connect this on the ControlBlog?)
    Exit (where must I connect this on the ControlBlog?)

    #97892
    Profile photo of MarcoCol
    MarcoCol
    Participant

    Another feedback from me, hopefully, anyone know an answer!

    to 1)
    I noticed another strange situation:
    The switch is turned off, then I connect the USB-power-suply and the Raspberry boots! But only until the Retripi-title-splash. Then I see the shutdown-command!
    When I then switch it to on, nothing happens, without that fading LED.
    If the switch is on and I then connect the USB-power-supy, the Raspberry boots too but then he will not shutdown.

    to 2)
    I test all buttons with “jstest” and they work.
    But the button I’ve chosen for Coin1, didn’t work in MAME?!
    Also I can’t use and Exit-button, because I didn’t know where to connect to on the ControlBlock!
    Or must I configure them in a config file?

    #97895
    Profile photo of guspaz
    guspaz
    Participant

    For the power switch to work correctly, the power must be connected to the ControlBlock power port, not the RPi power port.

    #97899
    Profile photo of MarcoCol
    MarcoCol
    Participant

    Ohhhhhh!

    I thought I must connect the power to the RPi?!
    Because I thought I saw that in photos of the manual.
    So then the ControlBlock gives the power to the RPi?!

    Thank you for your answer.

    #97931
    Profile photo of MarcoCol
    MarcoCol
    Participant

    So, I’ve tried that and it works perfect!
    So 1) is fixed.
    and 2) also almost fixed.
    But only almodst.

    As written, I’ve connected the Coin1 button, but in MAME it doesn’t work.
    Same for the Exit-Button.
    I’ve attached the Exit-Button to 2B.

    Any idea, what I must change or where I must connect it?

    General: Are there any shortcuts for other keys? Example: Using iPac2 a shortcut for Exit was pressing Player1 together with Player2…

    #98038
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Currently, the ControlBlock driver does not offer any shortcuts. However, I could add this functionality.

    Could you list some shortcuts that might have become “gold standards”?

    #98050
    Profile photo of MarcoCol
    MarcoCol
    Participant

    I found out now that I can set the controls pressing TAB in a game.
    When I then change it for all games and change after that controls of a single game, all other controls will not be overwritten from all games?

    So with the info of using TAB, I think no shortcuts are really needed.
    Sorry, I didn’t know that with the TAB…

    #98453
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Glad to hear that you found a solution. RetroArch emulators are configured such, e.g., that you can press the start and select buttons at the same time to exit the emulator.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar