Problems with some games with gngeo

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Problems with some games with gngeo

This topic contains 7 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #97797
    Profile photo of matpie
    matpie
    Participant

    Hi,

    using gngeo I have problems with some games. When I start such a game the neogeo start screen appears but after this the screen goes black. In the menu I can press “exit” again. With the same game.zip I dont have problems using fba emulator. Do you know why some games don’t start?

    Greets

    #97801
    Profile photo of Floob
    Floob
    Member

    Can you confirm your romset is corrent for gngeo?

    MAME versions and romsets on RetroPie

    There is a good chance the romset you are trying needs to be different, as fba and gngeo use different sets (see link above).

    And your bios file (neogeo.zip) comtains the right files?
    https://github.com/ymartel06/GnGeo-Pi/wiki/Bios-neogeo.zip

    Example setup here:
    http://dai.ly/x2icw2z

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97804
    Profile photo of matpie
    matpie
    Participant

    Thanks for your answer Floob.

    I am using Retropie 2.6 and there I put all the games in the neogeo-gngeopi roms folder. My gngeorc looks like this `p1control A=K122,A=J0B13,B=K120,B=J0B14,C=K97,C=J0B15,D=K115,D=J0B12,START=K49,START=J0B3,COIN=K51,COIN=J0B11,UP=K273,UP=J0B4,DOWN=K274,DOWN=J0B6,LEFT=K276,LEFT=J0B7,RIGHT=K275,RIGHT=J0B5,MENU=K27,MENU=J0B05829,MENU=K27,MENU=J0B0
    p2control A=K122,A=J1B13,B=K120,B=J1B14,C=K97,C=J1B15,D=K115,D=J1B12,START=K49,START=J1B3,COIN=K51,COIN=J1B11,UP=K273,UP=J1B4,DOWN=K274,DOWN=J1B6,LEFT=K276,LEFT=J1B7,RIGHT=K275,RIGHT=J1B5,MENU=K27,MENU=J1B0

    country usa
    system unibios

    rompath /home/pi/RetroPie/roms/neogeo-gngeopi
    `
    I use wireless ps3 controllers. The neogeo.zip contains all the files and unibios 3.1. There are only several games like MS5 or Spin Master which have these problems.

    #97805
    Profile photo of Floob
    Floob
    Member

    Have you confirmed your romsets are correct for gngeo (it could be why some work and some dont)?
    https://github.com/retropie/RetroPie-Setup/wiki/Managing-ROMs

    For example, there are about 200 (zip) files in the gngeo full romset.

    Any difference if you change system to “arcade” in your gngeorc ?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97813
    Profile photo of matpie
    matpie
    Participant

    I got the same behaviour after setting systems to “arcade”. There is no “dat” file in the /opt/retropie/emulators/gngeopi folder. I downloaded your pandora_gngeo_084_dat.zip. But do I need it?

    #97819
    Profile photo of Floob
    Floob
    Member

    The dat file is used to verify your roms.

    This is the guide that shows how to confirm your romsets are valid for gngeo:
    https://github.com/retropie/RetroPie-Setup/wiki/Managing-ROMs

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97827
    Profile photo of matpie
    matpie
    Participant

    There is a spreadsheet which confirms the gngeo problems with the games I mentioned. spreadsheet gngeo 0.8.4

    #97831
    Profile photo of Floob
    Floob
    Member

    Ah – thats good if its just the ones marked on there that you have issues with.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar