Problem with IPAC2 (usb) and different emulators

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Problem with IPAC2 (usb) and different emulators

This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of bratensosse bratensosse 3 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6042
    Profile photo of bratensosse
    bratensosse
    Participant

    Hi everybody,

    i built a bartop cabinet on my last holydays ๐Ÿ™‚ everything work fine with my favourite emulators (MAME and NeoGeo). Up to now a have a normally keyboard which is connected to my raspberry pi (512MB rev.2).

    Since today i am a proud owner of the IPAC2 USB-version. So i connected it to my raspberry pi and plays a little bit. But the emulators use different keymapping and i dont know how to chance it. I hope you can help me ๐Ÿ™‚

    Well, i installed at least the Source-code based installation. And here is a abstact of my es_system.cfg

    DESCNAME=MAME4allpi
    NAME=mame
    PATH=/home/pi/RetroPie/roms/mame
    EXTENSION=.zip .ZIP
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 4 "/home/pi/RetroPie/emulators/mame4all-pi/mame %BASENAME%"
    #COMMAND=/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/imame4all-libretro/libretro.so --config /home/pi/RetroPie/$
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    PLATFORMID=23
    
    DESCNAME=MAMEpiFBA
    NAME=mame
    PATH=/home/pi/RetroPie/roms/mamepifba
    EXTENSION=.zip .ZIP
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    PLATFORMID=23
    
    DESCNAME=imame4all
    NAME=mame
    PATH=/home/pi/RetroPie/roms/imame4all
    EXTENSION=.zip .ZIP
    COMMAND=/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/imame4all-libretro/libretro.so --config /home/pi/RetroPie/c$
    PLATFORMID=23
    
    DESCNAME=NeoGeo
    NAME=neogeo
    PATH=/home/pi/RetroPie/roms/neogeo
    EXTENSION=.zip .ZIP .fba .FBA
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%"
    COMMAND=/home/pi/RetroPie/emulators/gngeo-pi-0.85/installdir/bin/arm-linux-gngeo -i /home/pi/RetroPie/roms/neogeo -B /home/pi/RetroPie/emulators/gngeo-pi-0.85/neogeo$
    PLATFORMID=24
    

    As you can see, i use 3 different MAME emulators for different Games and the NeoGeo emulator to play all my favourite Games. I have tried to config the keys with the included tool in emulatorstation. But only one MAME emulator can be controlled. Fourthermore i tried to chance the retroarch.cfg in ./etc/ but this has no effekt.

    As a small info, the IPAC2 is an HID USB devide like a normal keyboard. For example if i press the insert-coin button it will show me a ‘5’ on the screen.

    So it will be very nice if someone can help me. And i am very sorry about my english, but is is not my native language. I hope you can read it ๐Ÿ™‚

    Looking forward to your ideas ๐Ÿ˜‰

    Thanks a lot

    Bratensosse

    #6111
    Profile photo of bratensosse
    bratensosse
    Participant

    Hi all,

    i havent solved the problem up to now. Only the mame4all-pi emulator works with my configurations. I used the “Start ES-Config” on the emulatorstation to map the keys. I think these settings are set in /RetroPie/configs/all/retroarch.cfg

    system_directory = /home/pi/RetroPie/BIOS
    config_save_on_exit = false
    video_threaded = true
    video_smooth = false
    video_aspect_ratio = 1.33
    video_shader_dir = /home/pi/RetroPie/emulators/RetroArch/shader/
    audio_out_rate = 48000
    audio_driver = alsathread
    input_autodetect_enable = "true"
    joypad_autoconfig_dir = /home/pi/RetroPie/emulators/RetroArch/configs/
    input_player1_a = lalt
    input_player1_b = left ctrl
    input_player1_y = space
    input_player1_x = lshift
    input_player1_start = 1
    input_player1_select = 5
    input_player1_l = z
    input_player1_r = x
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_exit_emulator = escape
    input_shader_next = m
    input_shader_prev = n
    input_rewind = r
    input_enable_hotkey = escape
    rewind_enable = true
    rewind_buffer_size = 10
    rewind_granularity = 2
    video_gpu_screenshot = true
    input_player0_l_y_plus = "nul"
    input_player0_l_y_minus = "nul"
    input_player0_l_x_plus = "nul"
    input_player0_l_x_minus = "nul"
    input_player1_l_y_plus = "nul"
    input_player1_l_y_minus = "nul"
    input_player1_l_x_plus = "nul"
    input_player1_l_x_minus = "nul"
    input_player2_l_y_plus = "nul"
    input_player2_l_y_minus = "nul"
    input_player2_l_x_plus = "nul"
    input_player2_l_x_minus = "nul"
    input_player3_l_y_plus = "nul"
    input_player3_l_y_minus = "nul"
    input_player3_l_x_plus = "nul"
    input_player3_l_x_minus = "nul"
    input_player4_l_y_plus = "nul"
    input_player4_l_y_minus = "nul"
    input_player4_l_x_plus = "nul"
    input_player4_l_x_minus = "nul"
    input_player5_l_y_plus = "nul"
    input_player5_l_y_minus = "nul"
    input_player5_l_x_plus = "nul"
    input_player5_l_x_minus = "nul"
    input_player6_l_y_plus = "nul"
    input_player6_l_y_minus = "nul"
    input_player6_l_x_plus = "nul"
    input_player6_l_x_minus = "nul"
    

    But only one Emulators works with this settings. The three other emulators have other key-mappings, and i dont know how to chance it.

    It would be very nice if someone can help me.

    Best wishes

    Bratensosse

    #6135
    Profile photo of bratensosse
    bratensosse
    Participant

    Hi everybody,

    well, i solved one problem. I can now change the keys for the pifba (i called it MAMEpiFBA in my es_system.cfg)

    the config file, that have to changed is ~/RetroPie/emulators/pifba/fba2x.cfg
    The ASCII codes of the keyboard u can find at /usr/include/SDL/SDL_keysym.h

    here is a promt ob my fba2x.cfg

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=308
    B_1=306
    X_1=304
    Y_1=32
    L_1=122
    R_1=120
    START_1=49
    SELECT_1=53
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    QUIT=27
    

    next step is to map the keys from my keybord to the NEOGEO emulator, i use the gngeo-pi-0.85 emulator in my es_system.cfg

    but i can not find the “insert coin” key i have tested all keys on my keyboard. In my ./gngeo/gneorc file the insert coin button is mapped on “3” but it doesnt work

    So please help me to find the right config file for gngeo-pi-0.85.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar