Problem with hotkeys

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #98269
    Profile photo of un0n
    un0n
    Participant

    Hi, I searched a lot about this but I can`t find a solution: I want to disable all hotkeys, and create my own hotkeys:
    Select + B button = Load State
    Select + Y button = Save State
    Can someone help me, please?

    Thanks

    #98270
    Profile photo of boydster
    boydster
    Participant

    You can edit your controller config to enable a hotkey by adding a line like this:
    input_enable_hotkey_btn = "x"
    Just put the number corresponding to the button you want to use in place of the x.

    Then, for setting the Save State and Load State buttons, use this:

    input_save_state_btn = "y"
    input_load_state_btn = "z"

    Again, just replace the y and z with the number of the button you want to assign.

    I was able to use that to set up my controller without needing to disable all hotkeys first.

    #98271
    Profile photo of un0n
    un0n
    Participant

    Thanks boydster! But I’m not doing this for a specific controller, I’m editing the retroarch.cfg file, for all controller, I add the lines like you said, but how can I make to have to press 2 keys in the same time?

    #98275
    Profile photo of Floob
    Floob
    Member

    boydster has a good suggestion in doing it on a per controller level (I only have two controllers, so only need to do it twice).

    If you want to set a full override, I’d check this video first to understand how they work.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar