Problem when changing keyboard layout

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Problem when changing keyboard layout

This topic contains 0 replies, has 1 voice, and was last updated by  lugge 2 years, 2 months ago.

Viewing 1 post (of 1 total)
  • Author
  • #109455


    Hi guys,

    I’m using RetroPie, and Linux in general, for some time.
    But now I encountered a really weired problem, which I cannot solve 🙁

    I encounter this problem when using a 3.2 based RetroPie image on both hardwares, Raspberry 1B and Raspberry 2B.
    This is why I think it’s an issue somewhere in the image (or I’m doing something wrong, more likely :-))
    When using a 2.6-based RetroPie image, everything is fine.

    So, my problem is, I can’t change the keyboard layout.
    There are several ways for achieving this, but none of them worked for me.

    What I tried:
    sudo raspi-config
    This is the standard way, using the Raspi setup script. I can change local and timezone. I can also change the layout (to de.DE), but this has no effect, even after restart. The setting seems just to get ignored by the system.

    sudo dpkg-reconfigure keyboard-configuration
    Script runs, but no effect, just like the raspi-config

    My last try was directly editing the keyboard file.
    Funny thing: when opening this file the XKBLAYOUT is already set to “de”.
    This means, the raspi-config script works (the keyboard file has changed to de), but the new setup IS NOT BEING RECOGNIZED.

    I also did a few reboots and tried sudo setupcon -v
    No errors, but I’m still being stuck with a gb layout.

    I wonder, is there some other file which overwrites my /etc/default/keyboard ??
    Why is my configuration not taken even after rebooting the Pie?

    What did change in the 3.2 images (or in the underlaying Debian)? 2.6 worked just fine and now I get this issue on Pie1 and Pie2. Strange…

    Any ideas?
    Best Regards,

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss