Please, help me RetroPie Community.

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Please, help me RetroPie Community.

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of newguy2015 newguy2015 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #89419
    Profile photo of newguy2015
    newguy2015
    Participant

    This is a Long Body if you dont want to read it all just read the bold.

    Up to this point I have had my Raspberry Pi for about a week, the past 3 days i have been trying to put an awesome thing, that amazing people, whom came from the GREATEST source of information – Google.com- on my Raspberry Pi I gave up the 2nd day and started to put raspbmc on it. I decided half way on getting it to work that I gave up to easy and would Google what I was doing wrong. I used an image for RetroPie because i got frustrated with installing raspbian -something like 9 time- the first time I had installed the image it worked except there was only like 4 emulators on it and I was let down – i did figure out on the 3rd day I had to put emulators on it and how to do it :)- got it running pretty good with gb and gbc but for some reason the gba needed a BIOS image from an actual gba -Googled and got it- I then started to look for the n64 emulator and the snes emulator -!no where to be found I had a ton of ROMS for them! still haven’t figure this part out- I decided that I was going to ssh into it and remembered that there is ALOT of information on how to get wireless internet through CLI – did everything from sudo nano /ect/network/interface (blank screen) to typing all the information in down to my ssid and password pressed CRT+X hit y and enter 2x gave me an Error (Error /ect/network/interface is not a file or directory) then I decided to get the raspbian GUI back to do it through the GUI -went to the CLI and typed sudo apt-get lxde and it said it was an invaild operation- So now I; 1. don’t have the N64 and SNES emulators. 2. I don’t have WIFI on the Raspberry Pi. 3. I don’t have a GUI to do it the easy way. I don’t care about 2 & 3 but the issue I am having is why have EmulationStation but cant get to the emulators?

    Oh and the Amazing thing was RetroPie with EmulationStation

    EDIT: Forgot to bold some of the exactual problem. Sorry for the grammar errors.

    Update: I formated and reinstalled the image to the sd card, and I deleted the roms folder off the flash drive. and I got 8/ 30 roms for the n64!!! 0/35 roms for the SNES…

    #89536
    Profile photo of sselph
    sselph
    Participant

    EmulationStation only shows emulators that have ROMs in their folders with the correct extension. So you just need to copy them over and it should work for SNES and N64. The easiest way for me is to just use the windows file shares that the retropie creates. So just browse the network and drop the roms in one of the snes/n64 folders.

    The expected extensions are in /etc/emulationstation/es_systems.cfg:
    SNES .smc .sfc .fig .swc .zip
    N64 .z64 .n64 .v64 zip

    A few other things:
    it is sudo apt-get install lxde

    it is /etc/network/interfaces

    Auto-scraper: https://github.com/sselph/scraper

    #90100
    Profile photo of newguy2015
    newguy2015
    Participant

    Ok not to be rude but let’s act like I know what an emulator is I am using .smc for the snes and .z64 .v64 for n64.

    If you read the entire post I was saying the raspberry pi said there is no file/directory also the editor was a black file

    #90101
    Profile photo of justinbeaird
    justinbeaird
    Participant

    To do wireless I do

    
    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf
    Then add to file 
    network={
        ssid="The_ESSID_from_earlier"
        psk="Your_wifi_password"
    }
    

    I got this from

    http://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

    #90105
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Ok not to be rude but let’s act like I know what an emulator is I am using .smc for the snes and .z64 .v64 for n64.

    If you read the entire post I was saying the raspberry pi said there is no file/directory also the editor was a black file

    I don’t think anyone suggested you didn’t know what an emulator was – they were giving you information on supported file extensions, and then information on the correct location of the interfaces file which you seemed to have not picked up on. I recommend you read through the advice given carefully.

    Regarding the black screen – you edited the wrong file/path. You probably made a typo. You said you were editing “/ect/network/interface” – there is no file of that name. Network settings are in “/etc/network/interfaces”

    You can configure wireless easily as with the post above.

    #92679
    Profile photo of newguy2015
    newguy2015
    Participant

    I figured it out forgot to update this but I expanded the file system in the Raspi-config I switched sd cards to a 32gb on and was trying to do it over the network with an ethernet cable plugged into it the WiFi dingle doesn’t work still I’ll try your guys solutions for that. Also is there anyway to get the n64 emulator to run smoother.

    As for buzz the first thing anyone who is half intelligent does when there emulator doesn’t work does is google why and what files it can work with. I’m not half intelligent but I figured that would be the first solution, but I should have blamed the memory first.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar