PiSnes Errors/Troubleshooting

This topic contains 4 replies, has 2 voices, and was last updated by  Stargex 3 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7426

    blaxzen
    Participant

    –fixed–
    For those having issues with no dpad supported in PiSNES, add this to your xboxdrv config/boot
    --dpad-only
    this will make it so that the dpad switched to axis 0 & 1 (instead of the left analog stick)

    Afternoon, I’ve used the retropie_setup.sh script to compile PiSnes.
    I have then adjusted the emulationstation to use PiSnes
    When I load a rom I get a black screen and then it kicks me back to emulationstation gui.

    When I exit back to terminal the entire system locks up (although it states that emulationstation has cleanly shut down, it seems that it is still receiving input from the keyboard but I can’t enter any commands. This is the error on the terminal screen from PiSnes:

    snes9x: unix/graphics.cpp:201: void S9xInitDisplay(int): Assertion '((EGLBoolean)0) ! =result' failed.
    aborted

    I deleted the entire PiSnes folder, recompiled via the setup script and let it redo the config files for emulationstation.

    I edited the config file for es_systems to load PiSnes again, and tried to boot a few different roms, got this error:

    play(int): Assertion '((EGLBoolean)0) != result' failed.

    I have switched to Snes9x and it seems to be working fine, but I’d like to check performance with pisnes.

    Thanks for any help!

    #7432

    blaxzen
    Participant

    Just an updated –
    Managed to get PiSNES working by using the binary available for download on the website.

    Not sure what’s going on with the compiled version, tried twice and both failed.
    Might be root permissions that are causing errors?

    Anyway, will try compile again and adjust things.

    As a sidenote, PiSNES runs really well compared to the standard emulator core in retroarch.

    #7485

    kitchuk
    Participant

    I actually prefer retroarch as Pisnes doesn’t work with mario all stars or megaman x 2 and 3

    Sent from my GT-I9300 using Tapatalk

    #8932

    zSprawl

    For anyone else looking to solve this problem, I did:

    cd RetroPie/emulators/pisnes
    wget http://pisnes.googlecode.com/git/pisnes.zip
    unzip pisnes.zip
    chmod 777 ./snes9x ./snes9x.cfg ./roms ./skins

    #9382

    Stargex

    Has anyone been able to create a new build of PiSnes? I need to create a build from source as I need to change some code for Sixaxis controllers. I’m getting the same error as blaxzen and would really like to figure out what I can do to get the build working.

    I am seeing this error too:
    play(int): Assertion '((EGLBoolean)0) != result' failed.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/