PiSNES .cfg help

This topic contains 3 replies, has 2 voices, and was last updated by  shadowfax1007 4 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4828

    shadowfax1007
    Participant

    I’ve asked on Reddit and I’ve asked on the Raspberry Pi forum’s gaming section, but no luck!

    I switched to using PiSNES with my RetroPie set up. Initially I had the issue some people have had, where there is no .cfg included with the sd-card image. So I updated PiSNES from source, problem solved.

    I tested out PiSNES and obviously the controls, whilst they worked, didn’t match up to the actual keys. A was B, etc etc. So I pulled the .cfg to my PC, rewrote it to match the correct key bindings and replaced the old .cfg.

    Despite this, PiSNES won’t read my .cfg file. It still uses the default keybindings. I’ve rewritten it numerous times to make sure its actually overwritten the old file, I’ve rebooted several times to be sure its reloaded etc. No luck!

    I’m using a generic usb SNES controller. From memory they were recognised as “DragonRise Inc. Gamepad” when I was playing around in terminal.

    Does anyone have any suggestions? I’m frustrated as hell and don’t really want to go back to RetroArch for SNES…

    #4832

    kitchuk
    Participant

    Have you tried editing the cfg via a SFTP connection? Try using a program called WinSCP and remotely logging in to the Pi. Also make sure no n of the buttons are duplicated in the cfg when editing. Good luck!

    #4843

    shadowfax1007
    Participant

    I’ve done all my edits via SFTP.

    I’ll double check for duplicates but I don’t recall there being any. Might also try doing the .cfg via sudo nano.

    #4848

    shadowfax1007
    Participant

    No luck. Any other suggestions guys?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.