Picodrive/DGen Controller issues

Home Forums RetroPie Project Everything else related to the RetroPie Project Picodrive/DGen Controller issues

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of windjammersfan windjammersfan 2 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #87687
    Profile photo of windjammersfan
    windjammersfan
    Participant

    I’m using a controller with 6 face buttons (MD 6 button pad style) but which also has two triggers (SNES style.) I thought because of the triggers and 6 face buttons it’d be idea for both SNES and MG/Genesis emulation. I’m having problems setting up the pad in either of the MD/Genesis emulators though.

    In Picodrive my main issue is that I can’t get buttons outside of the ABXYLR ones I set in the retroarch config to be used. I can bring up the retroarch config menu but while it seems like I can set the buttons I need (mapping to Retropad R2, etc.) I can’t get these to save. It hangs when I try this.

    I switched to DGen, but I can’t see where the config file is to change the control layout to my pad’s button numbers. It does, however, recognise the buttons that I can’t get to in Picodrive.

    Does anyone have any information about any of these issues? I’m using Retropie 2.5 beta.

    #87801
    Profile photo of windjammersfan
    windjammersfan
    Participant

    I found a solution to my problem. I was misunderstanding the retroarch menu options. The part of the retroarch ui that I thought would set the player controls wouldn’t save it’s settings in the retroarch.cfg, while the second place I found to set the controls would.

    This thread is what led me to the solution: http://blog.petrockblock.com/forums/topic/retroarch-configurations-refuse-to-save/

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar