Pi2: PSX Sound issues

This topic contains 13 replies, has 6 voices, and was last updated by Profile photo of neighbourhoodnerd neighbourhoodnerd 2 years, 3 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #88710
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    UPDATE:
    Resolved by updating to the latest version of the PSX emulator as suggested below. Dynamic Recompiler Core setting needs to be enabled.

    Hi all,

    I’ve been digging around in the forums for answers, but no luck yet. Please help!!!

    Issue:
    PSX sound is choppy:
    -BGMs crackle frequently
    -Cutscene music echoes and repeats

    This occurs even when emulation is at 60FPS.

    My configuration:
    -Pi2
    -32GB Class 10 Apacer MicroSD (OS and ROMs are stored on this)
    -1000mhz clock
    -512/512MB memory split

    Retroarch.CFG:

    system_directory = /home/pi/RetroPie/roms/../BIOS
    config_save_on_exit = false
    video_aspect_ratio = 1.33
    video_smooth = false
    video_threaded = true
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    input_rewind = r
    video_gpu_screenshot = true
    input_shader_next = m
    input_shader_prev = n
    video_shader_dir = /opt/retropie/emulators/RetroArch/shader/
    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/RetroArch/configs/

    I’ve tried:
    -Pretty much every software setting in Retroarch. Main settings, core settings.
    -I’ve also tried reducing graphical quality settings to see if that helped – no difference. Note that I get 60FPS most of the time anyway.

    What do I need to do to make PSX sound smooth?

    #88834
    Profile photo of orbiter
    orbiter
    Participant

    I am also experiencing the same type of issues with most PSX games. I have nearly the exact same config as neighbourhood nerd with a new PI2.

    – I’ve tried changing the audio codecs even with very little difference.
    – Tried changing the audio bitrate
    – Tried changing options in rgui in game to find differences
    – Setting process priority to retroarch process
    – Other things that were mentioned in the post above

    The best I got was less noise, but sometimes the audio would just drop completely. Looking at top process tree from inside of my SSH connection when playing a game shows not that much processor being used, but still no matter what I try, I get crackly sound – only on PSX games. Some are better than others. One of the worst is the Legend of Dragoon during cutscenes and during dragoon transformations. Final Fantasy VII seems to be working pretty solid though.

    Does anyone have best settings for sound? If so, please share!

    #88847
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    Hi,

    Maybe this will help (from the “Fine Tuning Retropie” thread.

    On my B+ I don’t have any issues whatsoever with the PSX emulator. But this requires an aggressive overclock and active cooling with heatsink and fan. It runs PSX at full speed with zero audio issues, lag, or long loading times when:

    arm_freq=1150
    core_freq=500
    sdram_freq=600
    over_voltage=8
    force_turbo=1

    Note the above settings WILL set your warranty bit. However its been pretty stable and never goes above 55C with heatsink and fan. Using BT PS3 controller.

    I have recently acquired a Pi2 and although it is noticably faster at many tasks, I did not see much of a difference with the PSX. It handles heavy action on the screen without dipping the frame rate, but that’s it. However N64 performance is MUCH improved, running Mario 64 and MarioKart 64 at full speed with literally ZERO glitches. However this isn’t the case with all games. Some simply do not run.

    My Pi2 is overclocked to 1100.

    Pi2

    #88855
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    So you suggest overclocking to 1100mhz? Any overvolt etc? Does this help with PSX?

    #88866
    Profile photo of gizmo98
    gizmo98
    Participant

    Hey guys. Have you recompiled pcsx_rearmed? There was a small bug in this module which prevented the installation of rpi2 builds. The module was fixed a day sooner or later as the 2.6.0 release. So please update RetroPie-Setup and try again.

    #88900
    Profile photo of orbiter
    orbiter
    Participant

    Thanks for the replies. I do not think I am in need of an overlock that will void my warranty. I have attached a picture that shows how much CPU and RAM is being used during a cinematic which has crackles and pops in the sound. The video never lags, just the sound has issues.

    I had just recompiled my system the day before yesterday. I’ll try the update again just in case.

    Attachments:
    #88907
    Profile photo of gizmo98
    gizmo98
    Participant

    Did you update RetroPie-Setup as well?

    #88915
    Profile photo of orbiter
    orbiter
    Participant

    I selected the option to “Update Retropie Setup Script” after running “sudo ./retropie_setup.sh” and I then rebooted. Is there anything else I needed to do to update that?

    I’m at work currently, and can’t test any games out, but I do have SSH access to the box back at home to try things if needed.

    #89023
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    I have just updated the retropie setup script and installed the PSX-Libretro from source.

    Unfortunately, this has actually made things much worse! Now the video lags as badly as it did on the Pi1!

    Has this update possibly deleted some settings needed to optimise the emulator?

    I’ve tested all the other systems to confirm the issue is definitely with this one. This is the case.

    #89194
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    Got it! The needed setting is
    Dynamic Recompiler = Enabled
    in Retroarch, Core Options settings.

    PSX now at 60FPS with flawless sound.

    You bloody legend!

    #89285
    Profile photo of dddaaannnhhh
    dddaaannnhhh
    Participant

    This is amazing news! I can’t seem to find the core options settings however. There’s no dynamic recompiler mentioned in my retroarch.cfg?

    Edit: Nevermind, I just added dynamic_recompiler = enabled to the retroarch.cfg in my retropie/configs/psx/ folder and it worked! No more sound stuttering. Castlevania Chronicles played great. I’m so happy for this! Thank your for finding this.

    #89290
    Profile photo of xylan
    xylan
    Participant

    yes it works, but the option disapars after reboot, and it look like optimisations are not always kept. strange

    #89293
    Profile photo of gizmo98
    gizmo98
    Participant

    There is a core options file as well. You could also set core options with RGUI (F1 or select+x).

    #89385
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    Yep, I set mine by opening the Retroarch settings whilst playing (good for testing settings!).

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar