Performance Increase

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of gizmo98 gizmo98 3 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4888
    Profile photo of shadowfax1007
    shadowfax1007
    Participant

    Is there anything else I can do to increase the emulation performance of the Raspberry Pi, running RetroPie?

    I’ve overclocked it, I’ve switched to the generally better regarded emulators like PiSNES. I read somewhere that someone forced 720p instead of running in 1080p to get better performance. Would that be beneficial? If so, how would I go about doing that?

    #4890
    Profile photo of retrofredde
    retrofredde
    Participant

    You can edit the /boot/config.txt file to have the pi running in lower resolution. I’m not sure if it’s just the CLI that run in lower res though, I have mine set to 1280×720 and I haven’t seen any performance differences worth mentioning but the CLI text is readable now. I get full speed in Snes games though with the CPU clocked to 1000 mhz, without using shaders.

    #4906
    Profile photo of kitchuk
    kitchuk
    Participant

    As refrofredde said try go in into the config.txt and changing the resolution to a lower scale. Mine is set to VGA mode at 4:3 aspect ratio.

    #4907
    Profile photo of kitchuk
    kitchuk
    Participant
    #4927
    Profile photo of shadowfax1007
    shadowfax1007
    Participant

    This could be helpful: https://github.com/retropie/RetroPie-Setup/wiki/Advanced-Configuration

    Cheers. Working non-stop all weekend, but I’ll give it a crack on monday

    #4980
    Profile photo of gizmo98
    gizmo98
    Participant

    You could optimize some files. I don’t know if performance increases.

    retropie-setup.sh, line 37
    —————–
    old: __default_cflags=”-O2 -pipe -mfpu=vfp -march=armv6j -mfloat-abi=hard”
    new: __default_cflags=”-Ofast -pipe -mfpu=vfp -march=armv6zk -mfloat-abi=hard -mtune=arm1176jzf-s”

    (According to http://elinux.org/RPi_Software)

    scriptmodules/emulators.shinc, line 791
    —————————————
    old: ./configure –prefix=”$rootdir/emulators/RetroArch/installdir”
    new: ./configure –prefix=”$rootdir/emulators/RetroArch/installdir” –disable-x11 –disable-oss –disable-pulse –enable-floathard

    (According to http://www.raspberrypi.org/phpBB3/viewtopic.php?t=56070)

    I have only tested pocketsnes and retrarch core. Delete RetroPie/emulators/RetroArch and RetroPie/emulatorcores/PocketSnes and do a source based installation.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar