PCXS-ReARMed – PSX roms – Sound is slow

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project PCXS-ReARMed – PSX roms – Sound is slow

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of downup downup 2 years, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #83564
    Profile photo of patrick500
    patrick500
    Participant

    Hi
    I use PCSX-ReARMed version 1.9 (June 20 2014) with emulationstation to run PSX roms.
    I have added BIOS and it’s loaded without error.
    Games start without issue, but after 1 min I have trouble regarding sound.
    The sound is ‘lagging’ or is played very slow.
    Sometimes, when the music or the voice are shutdown during a few seconds, the sound restarts normally. But after a short moment it begins again to be slow.

    When the game is loading, I have no particular error. (‘selected sound output driver : libretro’)
    I have tried with or without Bios and the problem seems to not be linked. I have the same ‘sound speed’.
    I observe the same thing whatever the used roms.

    Have you met the same trouble?
    How I can solve it?

    Thanks a lot for your help.
    Patrick.

    #83574
    Profile photo of downup
    downup
    Participant

    I can’t help you with yours question, but where should i place the Bios files?

    #83583
    Profile photo of patrick500
    patrick500
    Participant

    Hi
    about the bios, I have changed in the file :
    /opt/retropie/configs/all/retroarch.cfg
    the following parameter : System_directory
    System_directory = /home/pi/RetroPie/roms/BIOS
    With this parameter, all bios files are stored in this specific folder, for ALL emulators.

    The bios files for PSX are :
    SCPH1000.bin
    SCPH1001.bin
    SCPH7003.bin

    Now when you start a PSX game, the message ‘bios not found – bugs excepted…’ is removed.

    #83603
    Profile photo of downup
    downup
    Participant

    Hi, just tried to overlock my Raspberry Pi to

    arm_freq=1000
    gpu_mem=384
    avoid_safe_mode=1
    core_freq=450
    sdram_freq=500
    over_voltage=4
    force_turbo=0

    I have no sound errors in Dino Crisis 2 now 🙂 I think you need heatsinks and a fan to make this work without freezes

    Thanks the bios worked!.. but i had to lowercase scph…. .bin and …roms/bios

    #83679
    Profile photo of patrick500
    patrick500
    Participant

    Hi Downup,
    My previous config was :
    arm_freq=900
    core_freq=250
    sdram_freq=450
    over_voltage=2
    -> The sound was slow.

    Now I use :
    arm_freq=1050
    gpu_mem=384
    avoid_safe_mode=1
    overscan=1
    core_freq=500
    sdram_freq=550
    over_voltage=6
    and it seems to be better regarding the sound (but may be not perfect). I test with Mortal Kombat II.

    I have followed information about overclocking from here :
    https://github.com/retropie/RetroPie-Setup/wiki/Advanced-Configuration
    Of course I have got heatsinks but no fan.
    I have not yet tested the provided script from the link to check the temperature… I will do it.

    #83682
    Profile photo of downup
    downup
    Participant

    Nice, went with raspberry standard 1000mhz overclocking. Been playing dino crisis 2 now for 2hours runs smooth!

    Will build a case for my pi. But this is my setup 😛

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar