PC engine CD, and shaders

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of momaw27 momaw27 2 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #97455
    Profile photo of raycosantana
    raycosantana
    Participant

    Hi!

    Im using RetroPie 3 beta 2 on a Raspberry Pi 2

    I have two issues, first I cant play PC engine CD games, I put the SYSCARD3.PCE bios file with the roms and also in the bios folder but the games wont play, I tried both Japanese and American versions of this bios file. HuCard Games work fine.

    Second, shaders wont work, Im trying to use the scanline.glsl shader but it doesnt work, this is in the PC engine emulator also, this shader used to work but I made a clean install and It wont work since, here is my retroarch.cfg file

    #### Video
    
    # Video driver to use. "gl", "xvideo", "sdl"
    # video_driver = "gl"
    
    # Which OpenGL context implementation to use.
    # Possible ones for desktop are: glx, x-egl, kms-egl, sdl-gl, wgl.
    # By default, tries to use first suitable driver.
    # video_context_driver =
    
    # Windowed x resolution scale and y resolution scale
    # (Real x res: base_size * xscale * aspect_ratio, real y res: base_size * yscale)
    # video_scale = 3.0
    
    # Fullscreen resolution. Resolution of 0 uses the resolution of the desktop.
    # video_fullscreen_x = 0
    # video_fullscreen_y = 0
    
    # Start in fullscreen. Can be changed at runtime.
    # video_fullscreen = false
    
    # If fullscreen, prefer using a windowed fullscreen mode.
    # video_windowed_fullscreen = true
    
    # Which monitor to prefer. 0 (default) means no particular monitor is preferred, 1 and up (1 being first monitor),
    # suggests RetroArch to use that particular monitor.
    # video_monitor_index = 0
    
    # Forcibly disable composition. Only works in Windows Vista/7 for now.
    # video_disable_composition = false
    
    # Video vsync.
    # video_vsync = true
    
    # Forcibly disable sRGB FBO support. Some Intel OpenGL drivers on Windows
    # have video problems with sRGB FBO support enabled.
    # video_force_srgb_disable = false
    
    # Attempts to hard-synchronize CPU and GPU. Can reduce latency at cost of performance.
    # video_hard_sync = false
    
    # Sets how many frames CPU can run ahead of GPU when using video_hard_sync.
    # Maximum is 3.
    # video_hard_sync_frames = 0
    
    # Sets how many milliseconds to delay after VSync before running the core.
    # Can reduce latency at cost of higher risk of stuttering.
    # Maximum is 15.
    # video_frame_delay = 0
    
    # Inserts a black frame inbetween frames.
    # Useful for 120 Hz monitors who want to play 60 Hz material with eliminated ghosting.
    # video_refresh_rate should still be configured as if it is a 60 Hz monitor (divide refresh rate by 2).
    # video_black_frame_insertion = false
    
    # Use threaded video driver. Using this might improve performance at possible cost of latency and more video stuttering.
    # video_threaded = false
    
    # Use a shared context for HW rendered libretro cores.
    # Avoids having to assume HW state changes inbetween frames.
    # video_shared_context = false
    
    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
     video_smooth = false
    
    # Forces rendering area to stay equal to content aspect ratio or as defined in video_aspect_ratio.
    # video_force_aspect = true
    
    # Only scales video in integer steps.
    # The base size depends on system-reported geometry and aspect ratio.
    # If video_force_aspect is not set, X/Y will be integer scaled independently.
    # video_scale_integer = false
    
    # A floating point value for video aspect ratio (width / height).
    # If this is not set, aspect ratio is assumed to be automatic.
    # Behavior then is defined by video_aspect_ratio_auto.
    # video_aspect_ratio =
    
    # If this is true and video_aspect_ratio is not set,
    # aspect ratio is decided by libretro implementation.
    # If this is false, 1:1 PAR will always be assumed if video_aspect_ratio is not set.
    # video_aspect_ratio_auto = false
    
    # Forces cropping of overscanned frames.
    # Exact behavior of this option is implementation specific.
    # video_crop_overscan = true 
    
    # Path to shader. Shader can be either Cg, CGP (Cg preset) or GLSL, GLSLP (GLSL preset)
    video_shader = "/opt/retropie/emulators/retroarch/shader/scanline.glsl"
    
    video_shader_enable = true
    
    # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
    video_shader_dir = "opt/retropie/emulators/retroarch/shader"
    
    # CPU-based video filter. Path to a dynamic library.
    # video_filter =
    
    # Defines a directory where CPU-based video filters are kept.
    # video_filter_dir =
    
    # Path to a font used for rendering messages. This path must be defined to enable fonts.
    # Do note that the _full_ path of the font is necessary!
    # video_font_path = 
    
    # Size of the font rendered.
    # video_font_size = 32
    
    # Enable usage of OSD messages.
    # video_font_enable = true
    
    # Offset for where messages will be placed on screen. Values are in range 0.0 to 1.0 for both x and y values. 
    # [0.0, 0.0] maps to the lower left corner of the screen.
    # video_message_pos_x = 0.05
    # video_message_pos_y = 0.05
    
    # Color for message. The value is treated as a hexadecimal value.
    # It is a regular RGB hex number, i.e. red is "ff0000".
    # video_message_color = ffffff
    
    # Video refresh rate of your monitor.
    # Used to calculate a suitable audio input rate.
    # video_refresh_rate = 59.95
    
    # Allows libretro cores to set rotation modes.
    # Setting this to false will honor, but ignore this request.
    # This is useful for vertically oriented content where one manually rotates the monitor.
    # video_allow_rotate = true
    
    # Forces a certain rotation of the screen.
    # The rotation is added to rotations which the libretro core sets (see video_allow_rotate).
    # The angle is <value> * 90 degrees counter-clockwise.
    # video_rotation = 0
    

    #97462
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    for the unplayable games.
    firstly I’d say check the .cue files. just double check the spellings match with the rom and text in the .cue file.

    #97464
    Profile photo of raycosantana
    raycosantana
    Participant

    for the unplayable games.
    firstly I’d say check the .cue files. just double check the spellings match with the rom and text in the .cue file.

    They are fine, I play them in other emulators and they work just fine, .Cue files are correct.

    By the way, my second issue with the Shaders, it turns out the shaders do work but the default Shader option doesnt, video_shader = “/opt/retropie/emulators/retroarch/shader/scanline.glsl” is set and video_shader_enable = true is also set so it should work 🙁

    #97500
    Profile photo of momaw27
    momaw27
    Participant

    Yep, I’m having the same issue with PCE CD games. The HuCard games work fine… but no go with CD games.

    Anyone else?

    #97517
    Profile photo of raycosantana
    raycosantana
    Participant

    runcommand.log:

    Loading %s...
    
    Could not open referenced file "/home/pi/RetroPie/roms/pcengine/STAR_PARODIA_(NTSC-J)_[HCD2024].ISO": No such file or directory
    Error opening CD.RetroArch [ERROR] :: load_content :: Failed to load content.
    

    its right there :/
    The file is right there :/

    #97520
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    try renaming the .iso to .ISO,
    as it looks like the cue file is asking to open .ISO but your rom is named .iso

    #97522
    Profile photo of raycosantana
    raycosantana
    Participant

    try renaming the .iso to .ISO,

    Thanks but I already figured out what the problem was, the problem is that syscard3.pce needs to be spelled just like that, in the Wiki it states syscard3.pce needs to be spelled “SYSCARD3.PCE” all caps, this is wrong.

    I figured it out by checking another runcommand.log from a different game

    Error opening file: /home/pi/RetroPie/roms/pcengine/syscard3.pce

    #97660
    Profile photo of momaw27
    momaw27
    Participant

    Yeah buddy!

    That’s the ticket! Working like a champ now!

    Thanks man!

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar