Overlays makes games crash

Welcome Page Forums RetroPie Project Video Output on RetroPie Overlays makes games crash

This topic contains 8 replies, has 5 voices, and was last updated by Profile photo of patl patl 2 years ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #97705
    Profile photo of raycosantana
    raycosantana
    Participant

    Hi

    When I set any overlay option in Retroarch.cfg games wont run, PSX games do run but overlays are not displayed and if I try to change any overlay option in the settings (for example if I try to turn them off or change the scale) in the retroarch menu it crashes the PSX emulator

    Just to be clear, this only happens when I set then by default in Retroarch.cfg if I run the emulator without any overlay option set in retroarch.cfg and then manualy add them in the setting menu of retroarch they do work fine.

    The Retroach.cfg I edited is the one at /opt/retropie/config/all/

    Any idea what could it be? having to add the overlays every time I start a game is a chore 🙁

    Im using a PI 2 with Retropie 3 beta 2

    Thanks

    #97707
    Profile photo of patrickm
    patrickm
    Participant

    Hi

    When I set any overlay option in Retroarch.cfg games wont run, PSX games do run but overlays are not displayed and if I try to change any overlay option in the settings (for example if I try to turn them off or change the scale) in the retroarch menu it crashes the PSX emulator

    Just to be clear, this only happens when I set then by default in Retroarch.cfg if I run the emulator without any overlay option set in retroarch.cfg and then manualy add them in the setting menu of retroarch they do work fine.

    The Retroach.cfg I edited is the one at /opt/retropie/config/all/

    Any idea what could it be? having to add the overlays every time I start a game is a chore :(

    Im using a PI 2 with Retropie 3 beta 2

    Thanks

    This sounds like something in your config is amiss. I wouldn’t recommend messing with the config in /all/. You have to set a different resolution for each system for the scanlines to look right, anyway. Just set integer scale on (video settings) and then set a custom resolution (options -> video options) to your liking. Then apply the overlay and save the config (main menu -> save new config). You only need to set up each system once. Go to the folder in /opt/retropie/configs/ and open the folder corresponding to the emulator. Rename the “emulatorname.cfg” to “retroarch.cfg.”

    Also, make sure your video output is set up correctly by holding x when the game launches. Your video output should be at your monitor’s native resolution and retroarch render resolution should match this (set to “use video output”).

    Make sure that everything is named correctly – the .png and .cfg for the overlay you’re using should be named the same, and in the .cfg for the overlay it needs to be pointing to the right filename.

    #98608
    Profile photo of patrickm
    patrickm
    Participant

    Hi

    When I set any overlay option in Retroarch.cfg games wont run, PSX games do run but overlays are not displayed and if I try to change any overlay option in the settings (for example if I try to turn them off or change the scale) in the retroarch menu it crashes the PSX emulator

    Just to be clear, this only happens when I set then by default in Retroarch.cfg if I run the emulator without any overlay option set in retroarch.cfg and then manualy add them in the setting menu of retroarch they do work fine.

    The Retroach.cfg I edited is the one at /opt/retropie/config/all/

    Any idea what could it be? having to add the overlays every time I start a game is a chore :(

    Im using a PI 2 with Retropie 3 beta 2

    Thanks

    I can confirm the existence of this bug- overlays will crash RA if set by default, but can be loaded within RA.

    #98609
    Profile photo of patl
    patl
    Participant

    I think the problem is the file path information in your retroarch.cfg
    This entry in the config works for me:
    input_overlay = /opt/retropie/emulators/retroarch/overlays/wii/scanlines.cfg

    You cannot only write :
    input_overlay = wii/canlines.cfg
    or so.

    edit:
    I see there is also an entry in the config:
    overlay_directory
    But this don’t work for me if I only set a path here and select the
    image via input_overlay.
    Only a full File path as described above works for me.

    #98614
    Profile photo of patrickm
    patrickm
    Participant

    I think the problem is the file path information in your retroarch.cfg
    This entry in the config works for me:
    input_overlay = /opt/retropie/emulators/retroarch/overlays/wii/scanlines.cfg

    You cannot only write :
    input_overlay = wii/canlines.cfg
    or so.

    edit:
    I see there is also an entry in the config:
    overlay_directory
    But this don’t work for me if I only set a path here and select the
    image via input_overlay.
    Only a full File path as described above works for me.

    I’m already using the full file path; it doesn’t work.

    this was not an issue until I reinstalled everything about 2 weeks ago.

    This is only an issue with SNES and NES as far as I can tell. I’ve been getting a segmentation fault in my error log with this, which I posted to the retropie github.

    #98624
    Profile photo of patl
    patl
    Participant

    hmm .. Let me think … I think I really had a problem with the overlay’s, but I do not remember exactly which.
    But I think that’s the reason why I have compiled and noted the differences between the Retroarch Binary builds.

    I created a own Retropie Image using the new binary and since then used this.
    For me, the standard overlay function anyway without problems ….
    I’ll try it tomorrow with the original Retroarch Binary.

    #98651
    Profile photo of Floob
    Floob
    Member

    If you use the stock /all/retroarch.cfg and instead edit the system specific one, do you still get an issue?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98656
    Profile photo of zonitz
    zonitz
    Participant

    How are you editing your .cfg file, in linux, windows or WinSCP? If the edit is a paste from example a forum as this in windows the format and fonts could make it weird in linux (RetroPie). Try editing the file from the terminal or via SSH, remove and or re-add the (“) character and do a backspace on all ” ” whitespace eg. (input_overlay=) to (input_overlay =) again. Im thinking this could be the problem since when RA is writing the value it’s working (linux environment).

    #98657
    Profile photo of patl
    patl
    Participant

    Yes , this can really be the problem . I have tested it again with a completely fresh Retropie installation and it worked perfectly.
    But I made the entry without ”

    input_overlay = /opt/retropie/emulators/retroarch/overlays/wii/scanlines.cfg

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar