[Resolved] Original SNES Controller via usb adapter

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project [Resolved] Original SNES Controller via usb adapter

This topic contains 3 replies, has 3 voices, and was last updated by  asphixmx 2 years, 12 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #82625

    clockwork
    Participant

    Hello everyone,

    I’m encoutering problems with my snes controller !
    I’ve read a lot of threads about controller configuration but I can’t seem to find a solution to my problem.

    I’m using a B+ model, everything works great with a wired Xbox360 controller.

    I now want to use an original super nintendo controller with a usb adapter. I’ve plugged it in, set it up with emulationstation and everything works great… but not in game. Nothing responds.

    What I’ve tried so far :

    – Run retropie_setup.sh : When prompt to push the button to configure, nothing is recognized and I get a time out message.
    – Set the “input_player1_***_btn” lines in retroarch.cfg in /opt/retropie/configs/all/
    – Copy all these lines in the retroarch.cfg of the Snes emualtor.

    Does anyone know why the controller works perfectly in emulation station but is not recognized in configuration or in game ?

    Thanks in advance !

    #82626

    clockwork
    Participant

    Ok figured it out !

    I was letting the input_player1_joypad_index option to “0” but, because a Xbox Controller is already set up (even though not plugged in) I needed to set it to 1 !

    May help some other people !

    #84401

    colebucket06
    Participant

    If anyone still needs help resolving the issues associated with the Retrobit/Retrolink dual usb adapters for the original SNES controllers feel free to PM me or email me at colebucket06@gmail. There are a few things that need to be done to get this adapter working properly, but it will work. I will be working on a complete Instructables guide shortly for everyone else experiencing the same issues.

    #85557

    asphixmx
    Participant

    Hello,
    Clockwork, how did you make the adapter to work? Any special driver? When I press the up in pad, it is not recognized… neither the left. I saw many posts with this issue with no solution.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss