Onyl one gamepad working at a time

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Onyl one gamepad working at a time

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #85854
    Profile photo of thejuice
    thejuice
    Participant

    Hi,
    I have three gamepads that work really well in emulators when I use them one at a time (only one is plugged).
    But when I try to use two at once (for playing two-player games), only the first one (I guess in order of USB slots) works. And the one that works partially controls the second playr too : when I press left, down or if I press A, then both players in game are controlled. This does not occur if I press right for example… And the second gamepad is just useless and doesn’t respond at all.
    If I swap the gamepads in the USB slots, then the same problem occurs, but now it is the other gamepad that works.
    And the same problem is caused for any combination of gamepads (Logitech Rumblepad, Generic SNES USB gamepad, DragonRise). One by one they work well.

    There was a time when it worked, I don’t know what I have done to make it like this, any idea ?
    I copied each gamepad .cfg file in these directories, because I didn’t know which would be taken into account :
    /opt/retropie/emulators/RetroArch/configs/
    /home/pi/RetroPie-Setup/supplementary/RetroArchConfigs

    I uploaded my gamepad and various retroarch.cfg settings.

    Weird thing is that I seem to have too many retroarch.cfg files.
    The ones in each system are almost empty (just shader stuff), but then I have three with lots of settings ;
    /opt/retropie/emulators/RetroArch/retroarch.cfg
    /opt/retropie/emulators/retroarch/retroarch.cfg
    /opt/retropie/configs/all/retroarch.cfg
    In Which order are they read ? Should I delete any of them ?
    The gamepad config I see in /opt/retropie/configs/all/retroarch.cfg looks fishy to me…

    Thanks in advance.

    Attachments:
    1. config.zip
    #85856
    Profile photo of Floob
    Floob
    Member

    The retroarch file (and some others to be honest) is far from the stock version, and from your description you seem to have a 2.3 and 2.4 retropie running, all a bit odd.
    You could resolve the config setup you have, but may well be far easier to install a new image.

    This video may help with your multiple controllers.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85857
    Profile photo of evilllama
    evilllama
    Participant

    I just want to make sure I understand the situation here.

    First, you had all 3 controllers working at one time. For example, you could play a 3 (or 4) player game using all the controllers at the same time?

    If yes, you never updated anything after you were able to use all the controllers?

    If no, were you able to play 2 player games using 2 different controllers at the same time? Like in Contra to Battletoads?

    When you say “useless and doesn’t respond at all” did you mean the controller is a brick or did you mean “usless and doesn’t respond PROPERLY at all”?

    Does this happen with all emulators, or just one?

    Off the wall question, did you EVER change the emulator config file? For example, I altered the inputs on my NES emulator to make it more ergonomic when playing. Because I did this, I have to have the exact same controllers in the exact same ports every time I load up my pie.

    Like you, I have 2 different types of controllers, and the
    /opt/retropie/emulators/retroarch/configs
    config files for for one had the “B” button as
    input_b_btn = “0”
    and the other controller type is
    input_b_btn = “2”
    So when I wanted to change my mapping in the NES emulator, I altered the file
    /opt/retropie/configs/nes/retroarch.cfg
    by entering the command
    input_player1_b_btn =

    This made the joypad that was found as player one map in a specific manner. If I plugged the wrong controller in the port that was recognized first, the mapping was WAY off, and I first thought the controller was not fully functioning. That was when I (by accident) found that i had to use the same USB port for the same controller every single time.

    #85858
    Profile photo of evilllama
    evilllama
    Participant

    BTW, that video from Floob is how I got all my configurations for my controllers set up. Works like a charm… but I think he had a cold when he recorded it. 😉

    #85863
    Profile photo of thejuice
    thejuice
    Participant

    Hi, thanks for replying soooo quickly 🙂

    I said my gamepads were functioning before, two at a time yes. I never tried three at once.
    And then well yes, I updated like a fool, through the Retropie-setup script (installing binaries, updating, installing again, updating script…), through apt-get update and upgrade too… So that may be why I have a little bit of 2.3 and 2.4 mixed.
    I also configured my gamepad first through retropie-setup script doing a “register retroarch gamepad”, and then (don’t really know why), through es-config and the gui interface… It may be the cause of my problems having done it in several places…

    I’ll have a look at the video. 30 minutes wow, it must be very thourough !
    One thing I don’t understand (and hopefully will after watching), is why there would be a need of gamepad control in “gamepad_specific.cfg” and in retroarch.cfg too …
    And why by default I had cfg files with lines like “input_b_btn =…”, but read everywhere in the forums to write lines like “input_player1_b_btn = …” and “input_player2_b_btn = …”
    Like I said, it may be a little bit clearer after having seen the video.

    #85966
    Profile photo of thejuice
    thejuice
    Participant

    Hi,
    I watched the video. It’s long but there is a lot of information inside.
    So I did clean the following because I dread the full 2.4 installation :
    – Deleted the /opt/retropie/emulators/RetroArch/ folder from my 2.3 installation, while keeping the retroarch one.
    – Removed all reference of input_player1_* in the autoconfigs of each gamepad config…
    – Cleaned the main (“all”) retroarch.cfg file.

    But now I have discovered that even if the system seemed to have been updated to 2.4, it still used 2.3.
    And right now retroarch is not found in the path and I can’t launch anything.
    I’ll try to install via Retropie-Setup, but I’m also making up my mind about installing everything from scratch.

    Anyway I could learn a lot about the inner-workings of the system 🙂
    I’ll keep you posted of my findings.

    One question to Floob though : in the video you say that the name of the autoconfig gamepad files doesn’t matter, that the system will search in the files to find the one it needs… What if several files with distinct filenames refer to the same gamepads ? Will it simply take the first one or will it try to load both and therefore cause unexpected problems?

    #85974
    Profile photo of Floob
    Floob
    Member

    hmm, this is the folder used in 2.3
    /opt/retropie/emulators/RetroArch/

    its lowercase retroarch in 2.4.x

    I would definitely go for a 2.4.2 image and start clean so you know where you are.

    Thats a very good question about how exactly the auto detect files are used – in my experience the most recent valid file seems to be selected. You can always confirm what happens by running a rom and checking the yellow text at the bottom of the screen.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar