One controller config per emulator?

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie One controller config per emulator?

This topic contains 2 replies, has 2 voices, and was last updated by  jarkokoo 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #103743

    cnschulz
    Participant

    Gday,

    I am so close to having the perfect setup. Im running ES/RetroArch from OSMC on an overclocked (Turbo) Pi2. Im using a Rock Candy XBOX 360 controller.

    Emulators Im using are N64 and nes. They both work fine but Id like to configure the NES emulator to use the left stick for movement rather than the Dpad. This is what I did…

    – created a .cfg file for the controller from the front end and swapped the left stick and dpad controls.
    – created a retroarch-joypads folder under the nes config folder and placed the new auto config file (RockCandyGamepadforXbox360.cfg) in there.
    – edited the nes retroarch config and added this line at the top. “joypad_autoconfig_dir = /opt/retropie/configs/nes/retroarch-joypads”
    – restarted.

    It sort of works… When I load the game (super mario bros) it appears that controller input is disabled, but if I wait about 90 seconds it starts working!!

    So: 1. Is there a better/faster way of remapping the joystick for a single emulator?
    2. Where can i find that info?

    Cheers.

    #105767

    jarkokoo
    Participant

    When I load the game (super mario bros) it appears that controller input is disabled, but if I wait about 90 seconds it starts working!!

    I have the exact same problem, but I haven’t even configured emulator specific controls (yet). Just did the first time config and then edited it a bit. I’m using RetroPie 3.0 and Wii Classic pad with Mayflash adapter. Works like a charm, but the delay is really weird AND annoying and sometimes totally random length. 🙁 It also feels like pressing some buttons can activate the controller faster, but I’m not 100% sure about that, I’ll have to experiment more.

    #106067

    jarkokoo
    Participant

    Ok, I can now confirm, that the controller comes active right after I press both of the shoulder buttons down simultaneously. It also seems, that if I have the controller being idle a while, it kind of goes into “sleep” and then I need to activate it again via that 2 button press.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/