olimex a20 .Is it compatible?

Home Forums RetroPie Project Everything else related to the RetroPie Project olimex a20 .Is it compatible?

This topic contains 13 replies, has 2 voices, and was last updated by Profile photo of gizmo98 gizmo98 2 years, 8 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #9082
    Profile photo of octubrq
    octubrq
    Participant

    sorry for my english .I have correctly configured hindfoot and raspberry, but some games are slow or do not have good sound and have read that not enough power the raspberry. has overclock to 900 mhz. Retropies? Olimex is fully compatible with 20? thanks

    #9176
    Profile photo of gizmo98
    gizmo98
    Participant

    I will check it out this week.

    #9184
    Profile photo of octubrq
    octubrq
    Participant

    ok thanks!!

    #10433
    Profile photo of octubrq
    octubrq
    Participant

    Have you try it?

    #10470
    Profile photo of gizmo98
    gizmo98
    Participant

    I have tried it, but i wasn’t successful. I could not boot from a SD card. It seems to be the A20 needs a micro SD card. I ordered one and will check it out this week. 😉

    #10512
    Profile photo of octubrq
    octubrq
    Participant

    to see if you’re lucky!

    #11862
    Profile photo of octubrq
    octubrq
    Participant

    I read that does not support the graphics card. Please see if you can confirm

    #11877
    Profile photo of gizmo98
    gizmo98
    Participant

    RetroPie-Setup is not compatible with the olimex debian image at the moment. RetroPie-Setup cannot disable the autostart of Xorg/XFCE and emulationstation cannot start if Xorg is running.

    With minor changes of the RetroPie-Setup Script it should be possible to run emulation station and Retroarch cores.

    #11878
    Profile photo of octubrq
    octubrq
    Participant

    Shame!thanks for all

    #11880
    Profile photo of gizmo98
    gizmo98
    Participant

    There is no defined way to target different platforms at the moment. I will try to fork the current RetroPie-Setup for olimex A20.

    But first of all i will disable the autostart Xorg manually and check out if emulationstation is running.

    #11933
    Profile photo of octubrq
    octubrq
    Participant

    thanks my friend

    #17530
    Profile photo of gizmo98
    gizmo98
    Participant

    Update:
    -I modified retropie setup script.
    -You can build and run emulationstation. Emulationstation starts only if X is running. It runs slow as hell, because it uses mesa GL libs. GLES builds will not start at the moment. Should be a emulation station problem.
    -You can build and run Retroarch. At 720p the framerate drops to 40-50Hz. Shaders cannot be used (too slow). 480p or 576p should be fast enough.
    -The Mali kernel module r3p0 is too old. Only one core of the MALI400MP2 dual GPU is used. If the kernel module r3p2-relxx could be build the framerate should be much better.

    #81695
    Profile photo of gizmo98
    gizmo98
    Participant

    Update:
    -It is possible to build SDL2 and EmulationStation with GLES support. Runs really smooth under X.
    -It is also possible to compile RetroArch with GLES support.
    -GB and SNES cores are running atm. Cannot start PCSX, cannot build pocketsnes. Have not tested other cores.

    #81725
    Profile photo of gizmo98
    gizmo98
    Participant

    Update:
    -GB, GBC, SNES, GENESIS, MASTERSYSTEM and PSX are running fine. (resolution 576p)
    -Cannot build mupen64plus-rpi and gasp.
    -Shaders are slow as hell. Smooth video runs good.
    -SNES: Secret of Mana 2, Starwing and Super Mario RPG run at full speed.
    -PSX: Gran Turismo runs good.

    Source:
    sudo git clone –depth=0 git://github.com/gizmo98/RetroPie-Setup.git

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar