Noob Needs some help

This topic contains 2 replies, has 2 voices, and was last updated by  derrabe 3 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #83607

    derrabe
    Participant

    Hi,

    I just got my first raspberry pi yesterday and I bought with the
    intention to run retropie on it and play all the games from my
    childhood. I bought 2 usb generic snes controllers off amazon for
    this. So far I seem to have gotten it configured and have roms
    transferred to it an playable. I currently have 2 problems.

    1. I have managed to get the controllers to work in the games and playable on several NES and SNES games and also 1 or 2 mame games. I bought this with the hope that I wont need a keyboard once I have it configured. The biggest hurdle for that so far is the inability to exit out of a game and select another with out having a keyboard plugged in. I have spent several hours today searching this forum and google to try to fix this and so far no luck. I think I found the right file but maybe not. /opt/retropi/emulators/Retroarch/configs/

    
    input_device = "2Axes 11Keys Game  Pad"
    input_driver = "udev"
    input_b_btn = "2"
    input_y_btn = "3"
    input_select_btn = "8"
    input_start_btn = "9"
    input_up_axis = "-1"
    input_down_axis = "+1"
    input_left_axis = "-0"
    input_right_axis = "+0"
    input_a_btn = "1"
    input_x_btn = "0"
    input_l_btn = "4"
    input_r_btn = "5"
    
    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "4"
    input_save_state_btn = "0"
    input_load_state_btn = "1"

    2. The other ting I would like and not even sure where to look is when I was a kid I remember these games being a little more crisp. I know i am on a hd 1080p tv and not an old tube tv but some of the things are so blurry if you didnt know what they were in the original then you would have no clue what it is now. Is there any way to crispen up the graphics to make it closer to what I remember. I have no idea where to look for this.

    Thanks in advance

    #83627

    Floob
    Member

    Check towards the end of this video for the hotkey
    To be honest your file contents look ok. Maybe that line space is confusing it?
    You could try pasting that into your main retroarch.cfg instead as something in there may be overriding it
    /opt/retropie/configs/all/

    Check this video for the retro look:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83705

    derrabe
    Participant

    Ok I solved my problem, I didn’t realize I need to be sudo to change the file so I saved it and added a 1 on the end then deleted the original and renamed the 1 file to the original name. This did not work, neither did hard coding it into the retroarch.cfg file. I backed out that part and delete the controller config file and then ran the raspi_setup.sh again and the ran retro arch setup and with the newly created file and running in sudo mode I was able to edit the lines in and they now work fine. I haven’t had time to play with video setting yet.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss