No picture in DGen

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of jcx1028 jcx1028 3 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2557
    Profile photo of jcx1028
    jcx1028
    Participant

    Until today, I could not get Genesis roms to work properly. They all simply froze on the DGen logo. But then I converted my Sonic the Hedgehog .bin file to an .smd file, and it worked great. At that point, that was the only Genesis rom on the Pi. So I went ahead and converted all of my other Genesis .bin files — all 900 of them — and copied them onto the Pi. And now, when I try to run any of them — including the Sonic file that had previously worked fine — I get sound, but no picture.

    Is this a memory issue or something? Any advice?

    If it makes a difference, I’m using HDMI.

    #2564
    Profile photo of petrockblog
    petrockblog
    Keymaster

    In my experience, DGEN can work fine for one or two ROMs and, when starting a third ROM, the screen may stay black – even when using HDMI video! For me, the only way to solve this temporarily is to restart the RPi.

    I added the Genesis libretro core “Picodrive” to the RetroPie Setup Script. I would suggest to try this. It does not come with the SD-card image, but using the binaries-based installation will install and configure it on your RPi.

    #2584
    Profile photo of jcx1028
    jcx1028
    Participant

    Well, the problem appears to have fixed itself. I deleted all Genesis roms and then copied them back over and now they all work. I don’t even think I restarted it. Whatever sorcery caused them to start functioning is good enough me.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar