No Keyboard after configuring PS3 Controller

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie No Keyboard after configuring PS3 Controller

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of gizmo98 gizmo98 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #109760
    Profile photo of HoustoneD
    HoustoneD
    Participant

    I have been searching over and over for someone with a similar report of this issue.

    I know i am missing something.

    Summary-
    Freshly loaded image of RetroPie 3.2.1 on Rpi2.
    Updated setup script
    Install Kodi v15 (using advice from another thread @ petrock)
    Rebooted and plugged in PS3 controller via USB
    Configured PS3 Buttons in Emulation Station screen

    Now my controller works to browse ROMS and all other EmulationStation menus. The keyboard is unresponsive until i am in retropi_setup.sh or raspi config or anything similar. One thing i have noticed though is that when the screen dims after a period of inactivity, pressing a keyboard button “wakes up” the emulationstation, brightening the screen. This tells me i am most likely just needing to map my keys somewhere in a a config file. the question then becomes “Which file?” Also, is there a way to have both the PS3 controller and keyboard work simultaneously in emulationstation?

    Also, i have one small issue with the keyboard functionality when i run the experimental Kodi build. I have the iPazzPort Raspberry Pi Mini Wireless Handheld Remote Control Keyboard with Multi Touch Touchpad. Everything seems to work fine with the exception of the volume buttons at the top left side. I am sure it is simply a matter of mapping these key IDs to the F9 and F10 keys. I just need a little direction on how to do this. Again, i am sure it is probably in a cfg file somewhere. just i dont know which one!

    Thanks in advance!

    #109769
    Profile photo of gizmo98
    gizmo98
    Participant

    Did you setup keyboard as input device? Otherwise only button F4 is working.

    #109776
    Profile photo of HoustoneD
    HoustoneD
    Participant

    After a bit more investigation i think i may have found my answer. i am not at home right now so i cannot physically do any more than a remote ssh session allows.

    To answer your question – Yes. I originally setup my keyboard as an input device. After rebooting, i plugged in my PS3 via USB and configure it as an input device. After this, i was unable to navigate emulationstation using my keyboard.

    I am going to assume what i need to do is go to setup script > Setup /Configuration > Configure Input Devices for RetroArch > Configure keyboard for use with retroArch

    Although, i am not 100% sure this is going to do anything- Will RetroArch settings also be used in the emulationstation interface? i would like to be able to navigate the menu using keyboard and/or joystick

    #109809
    Profile photo of nickademusss
    nickademusss
    Participant

    I have the exact opposite issue, keyboard is the only way I can navigate ES, my PS3 controller only works in the games. I have run the retroArch setup and it didn’t make any changes. Mine also wakes the system up with the PS3 controller so I know it “sees” it in the ES menu….

    Very weird…

    #109835
    Profile photo of HoustoneD
    HoustoneD
    Participant

    I have the exact opposite issue, keyboard is the only way I can navigate ES, my PS3 controller only works in the games.

    you just blew my mind.

    Im pretty sure that whichever device you use to complete the configuration on first boot is the device that will be used in ES. You can redo this config by either pressing the mapped start or select button- cant remember which one.

    I went home last night and did a little bit of drinking and had some friends over. Im not sure exactly what transpired, but i feel i have made peace with my situation. I beat Mortal Kombat on Genesis after 2 decades of not playing it. I ran the PS3/Bluetooth install, and then the ReatroArch Input setup for my PS3 controller. Tonight i want to try the RetroArch Input config for my keyboard and see if they work simultaneously, or if the keyboard overtakes the joypad as default. Ideally, i’d like both to work. I will post results.

    #109869
    Profile photo of gizmo98
    gizmo98
    Participant

    If your iPazzPort Keyboard is connected over bluetooth the ps3controller driver “sixad” certainly interrupts this connection. sixad disables bluetooth daemon. If you need ps3controllers and other bluetooth devices at the same time sixad must be replaced with a newer bluetooth daemon which has sixaxis support (there is no install script up to now).

    #110344
    Profile photo of HoustoneD
    HoustoneD
    Participant

    Gizmo- My iPazzPort has its own usb dongle. I am not sure what wireless protocol it is using. i guess it is possibly bluetooth, but not connecting through my rocketfish BT dongle. Could this still be the issue?

    #110369
    Profile photo of gizmo98
    gizmo98
    Participant

    If your keyboard connection breaks up if you type “sudo service bluetooth stop” ps3 driver is the problem.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar