No joysticks found?

This topic contains 10 replies, has 3 voices, and was last updated by Profile photo of RetroMarine RetroMarine 2 years, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #4959
    Profile photo of karloss
    karloss
    Participant

    This is winding me up…

    I have beening using my system, all week without any issues, but this morning i turned it on and none of my gamepads work…

    When emulationstation loaded it was doing nothing, so i deleted the es_input and rebooted, and I have No Joysticks detected…

    the funny thing is this has been working for a week without any changes, i can also see the joysticks found upon boot, and if i do a lsusb, i can see both controllers plugged in..

    I have unplugged my hub and plugged a control straight into the pi, no difference, I have also re-burnt the 1.9.1 image to sdcard, no difference. and also tried another pi, no difference.

    If i plug the pads into my windows pc, they are both detected and work staright away..

    so i am stumped, anyone else have any ideas?

    thanks

    #4960
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Do they appear as /dev/input/js0, /dev/input/js1 or similar?

    #4962
    Profile photo of karloss
    karloss
    Participant

    hey pet, how can i see if that is the case?

    thanks mate

    #4963
    Profile photo of petrockblog
    petrockblog
    Keymaster

    You need to EmulationStation by Pressling F4 and then use the command

    ls /dev/input

    to list the content of the input folder. If Raspbian recognizes your game pads they will show up as js0 and js1 in that folder.

    #4964
    Profile photo of karloss
    karloss
    Participant

    Ok, i will check that once my kids are in bed…

    they have been working fine, and all of a sudden stopped, but like i said, still work on win7, so they not broken per-say..

    #4966
    Profile photo of karloss
    karloss
    Participant

    Hey pet,

    I have no idea why, but neither of my gamepads are now working or listed…they were listed and working fine last night, when i do lsusb i get

    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 05dc:a815 Lexar Media, Inc.
    Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
    Bus 001 Device 006: ID 0d8c:000e C-Media Electronics, Inc. Audio Adapter (Planet UP-100, Genius G-Talk)
    Bus 001 Device 007: ID 0079:0006 DragonRise Inc. Generic USB Joystick
    Bus 001 Device 008: ID 0079:0006 DragonRise Inc. Generic USB Joystick

    and when I do ls /dev/input

    pi@raspberrypi ~ $ ls /dev/input
    mice

    So something has gone wrong, it seems strange that even reburing the sd-card hasn’t sorted it?

    any ideas? I only managed about 4 days of my table act finished and now the controllers have stopped 🙁

    #4976
    Profile photo of karloss
    karloss
    Participant

    Could it be that my hub’s power isn’t working right, and though the device is being picked up on the pi, it is not being registered properly? i’m completly stumped at why this has as stopped working…

    but it might answer why I get the same via the usb on pi and my hub?…i need my system to work again.. 🙁

    #4979
    Profile photo of petrockblog
    petrockblog
    Keymaster

    It might be a power issue with the hub, right.

    #4989
    Profile photo of karloss
    karloss
    Participant

    well, last night I tried using a different usb hub, and that made no difference at all, so it wasn’t the hub..

    I just can’t work it out, I installed debian into a virtual machine and plugged the gamepads in, and they both worked fine, so they are not at fault.

    is there anyway for me to force the joy0/1? what infuriates me the most is the fact everything was working one night, went to play the next day, and nothing works, and no matter what i try, they do not work on the pi any-more, i have even tried a different pi, and like i said, re-imaged the sdcard, but no change..i have always used these gamepads and never had a single issue with them before..i guess if no one has any idea i will have to give up and scrap the table..

    #5028
    Profile photo of karloss
    karloss
    Participant

    HI pet,

    I seem to have made some progress, though I don’t know why I need to do it, and I run into another issue..

    I used to be able to burn the 1.9.1 image plug in pads and they work fine, but this doesn’t seem the case..

    But if I use the rpi-update and update the pi kernel, on reboot the pads start working again, the only problem is, none of the emulators work, they all complain about eeprom error (picodrive) and not being able to read config file (snescore)

    I rebuilt the system with a source install last night, and thought the pads still work, none of the emulators started working.

    do you have any idea, why i would now need to do this for the pads to work? and if there is a way i can do it without having to update and stuff? as that doesn’t seem to be working right for me..

    thanks

    karl

    #81700
    Profile photo of RetroMarine
    RetroMarine
    Participant

    Karl,
    Did you ever figure this out? My pi is doing the exact same thing. One minute everything is fine, the next minute, no controllers detected.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar