No hotkeys working (RB2 / Retropie 3.4 / NES30 Pro)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie No hotkeys working (RB2 / Retropie 3.4 / NES30 Pro)

This topic contains 8 replies, has 3 voices, and was last updated by  echdareez 1 year, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #114899

    echdareez
    Participant

    Hi there,

    Got my Retropie almost working 100% – full screened, no black borders, full sound on HDMI or audiojack, resolutions are set and the shaders are applied. But just that dreaded controller… I was able to connect my NES30 PRO and it works but the hotkeys don’t. Tried adding them in retroarch.cfg but without any luck.

    My retroarch.cfg
    My 8BitDoNes30Pro.cfg

    Anyone who might have the time to look at the 2 cfg’s above? Both can be found under the /opt/retropie/configs/all and /opt/retropie/configs/all/retro-joypads folders..
    thanks!
    /dimi

    #114900

    Floob
    Member

    The button codes for that should be

    input_b_btn = "12"
    input_y_btn = "15"
    input_select_btn = "21"
    input_start_btn = "22"
    input_a_btn = "11"
    input_x_btn = "14"
    input_l_btn = "17"
    input_r_btn = "18"
    input_l2_btn = "19"
    input_r2_btn = "20"
    input_l3_btn = "24"
    input_r3_btn = "25"

    Your file doesnt look like it was generated by EmulationStation? It will generate the correct hotkeys for you.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #114922

    echdareez
    Participant

    hi there Floob,

    May I first say how much I’ve enjoyed your tutorials? Immediately subscribed of course πŸ˜‰

    Also my thanks for your reply – actually it was created by EmulationStation – not sure how I would create it otherwise (and be doubtful about the correct keycodes).

    As my values are off (6/7/8/9 instead of 17/18/19/20), could it be that this has something to do with the mode my NES30 PRO is in? I start it up in Mode 1 (joystick)… And besides that : even with these ‘odd’ values, normal controls do work perfectly, it’s just the hotkey combo’s that don’t. Strange…
    Just trying to understand what’s happening πŸ™‚

    cheers,
    /dimi

    #114935

    Floob
    Member

    But your file has manual edit in, for example your name is in there and other comments.

    Which version of RetroPie are you using? Was it from an image?

    You may need this line in your retroarch.cfg
    input_enable_hotkey = nul

    but I would revert your retroarch.cfg back to default until you get it working.
    That controller config still looks odd though, I’ve never seen ES generate one like that.
    I would delete it and regenerate it with ES.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #114948

    hobbswon
    Participant

    Same exact thing happened with me in 3.3…the cfg file ES created show values co.pletely opposite of what the config shouod look like…but some of the controls work. Just have to go in and manually edit them.

    #114950

    echdareez
    Participant

    Thanks guys for the help!
    @ floob : you’re the man! Thanks to your tip, it got me started on a different track and well, first a quick answer on your reply : yes, the file was initially created by ES and I added some extra lines from sample .cfg files on the github… And I started out with 3.2 and updated it to the latest version…

    @ hobbswon : it did? Well, I had to solve it differently…

    For all those interested, this I discovered after one hour of troubleshooting :
    – the file es_input.cfg in the .emulationstation dir has the settings for the operation in ES : if your controller works in ES but not in Retroarch (RA from here on), that’s why. It had me puzzled and now it seems logical but still…
    – modifying the initial retroarch.cfg (as provided in Retropie) seemed to be a deadend …
    – and this is my initial source of confusion – I thought that ES and RA were linked but they aren’t… Not sure how the files in the retroarch-joypads are used as I had this working using the retroarch.cfg (the 8BitNES30Pro.cfg isn’t used in RA it seems)
    – what I did : I entered RA from ES, saved the config to another file (just saving it seems to be broken) and renamed this to retroarch.cfg (under the configs/all directory)
    – after that : entered RA again from ES, entered the hotkeys/input section and defined everything that I needed, saved the config to another file + rename to retroarch.cfg
    – pico’d in some more settings directly into the retroarch.cfg (enabling shaders / correct location for the shaders / fontsize and so on…)
    – in commandline : verified that the retroarch.cfg under each subsection (eg GB or SNES) has just a few lines with an include to the main retroarch.cfg
    – entered ES once more, started a game and oh hell yeah, it worked πŸ˜€

    So yeah, I’m a happy camper πŸ™‚ Got a working Retropie at the moment, my controller does wonders and well, more importantly, I’ve learned a lot πŸ™‚

    thanks again!
    /dimi

    #114956

    hobbswon
    Participant

    I’m confused why did you make two separate retroarch.cfg files? Are these stored in two different locations?

    #114960

    Floob
    Member

    Glad its working, but for reference no changes to the retroarch.cfg are needed. It has a default setting to autoload the controller configs in /opt/retropie/configs/all/retroarch-joypads which is where ES should generate your clean controller file for you.

    Here is a bit of info on how it works

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #115212

    echdareez
    Participant

    Pardon me for the late reply : been busy πŸ™

    @ hobbswon : not at all – but have a look at these two locations :
    Menu entry to save retroarch.cfg
    Result saving new config

    So : when I just try to save the retroarch.cfg as it is (save current config – see link 1), nothing happens (no message is displayed in the lower left bottom – I also checked the contents of the retroarch.cfg), when I go to “save new config”, the message appears as seen in the 2nd link… And retroarch does something… A bug?

    @ floob : thanks for the info and yeah, it normally should but for some reason, it doesn’t on my config πŸ™ And I have to use retroarch.cfg for the hotkeys… Will check your video tomorrow but I think I’ve already seen it (and followed it along)

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/