No auto config for joystick

This topic contains 1 reply, has 1 voice, and was last updated by  edtrud 3 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #84181


    Hello, first off i am kind of new to retropie. I installed it a couple days ago and i have been figuring everything out slowly. I used to have an issue were the rom load sequence would start but then it would kick me back into the ES gui. I was able to fix that with using an older verion of But now when the rom loads I cannot use the joystick. Maybe its just that i am doing something wrong or just misinformed. I have read alot of the forums and on the’s site of mupen64plus. Everything there is kind of said vaguely and in a general sense and nothing specific.

    My current dilemma is that I bought a USB controller from Walmart (Local store) mostly because I didnt want to wait for shipping if i were to buy a n64 controller because of the holidays and such. So i was able to configure the controller with ES and i can navigate through the gui and play some of the pre-installed roms, but my controller doesnt work in the mupen64plus environment. I get a error code in the loading sequence: Input Error: No auto-config found for joystick named ‘My-POWER CO.,LTD. 21n2 USB Joystick’ in InputAutoConfig

    So from there i located the file for inputautoconfig and i tried renaming the controller to the above description but still got the same error message. So i am not sure if there is a way to configure it through mupen instead of inputting the information manually. I copied some controller configs just to test out and see if the controller would be recognized at all, but with no success.

    This is the config that I used. I removed i think it was SDL1 controller and pasted this in instead (I renamed the name to my My-POWER CO.,LTD. 21n2 USB Joystick.

    [My-POWER CO.,LTD. 21n2 USB Joystick]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(0)
    A Button = button(2)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(6)
    L Trig = button(4)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    Any help is appreciated!



    I just read on a forum that inputautoconfig.cfg is not the same as mupen64plus.cfg?
    is this correct?

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss