No Amiga emulation

Tagged: 

This topic contains 39 replies, has 14 voices, and was last updated by  Floob 4 years, 2 months ago.

Viewing 35 posts - 1 through 35 (of 40 total)
  • Author
    Posts
  • #2836

    jzp74
    Participant

    Hi all,

    This may well be a stupid question: I flashed the latest version of retropie (v1.8.1) on an SD card and gave it a spin. Can it be that this version does not contain an amiga emulator? There no uae4rpi executables to be found anywhere. There is a folder ~/RetroPie/emulators/uae4rpi but this contains no programs only sources? Can anyone confirm? Am I doing something wrong?

    Thanks!

    #2856

    petrockblog
    Keymaster

    You are right – I did not notice this before.

    When compiling uae4rpi, an error is generated, saying

    /usr/bin/ld: warning: libvorbisfile.so.3, needed by /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so, not found (try using -rpath or -rpath-link)
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to 
    ov_time_seek
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to ov_clear
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to ov_pcm_total
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to ov_open_callbacks
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to ov_info
    /usr/lib/arm-linux-gnueabihf/libSDL_mixer.so: undefined reference to ov_read
    collect2: ld returned 1 exit status
    make: *** [uae4all] Error 1
    #2865

    jzp74
    Participant

    Thanks for your answer.

    Does this mean you will compile a new version of uae4rpi? Or do you need help compiling?

    #2977

    jzp74
    Participant

    For some reason the Retropie image (v1.8.1) contains a wrong link.

    /usr/lib/arm-linux-gnueabihf/libvorbisfile.so.3 is a file and should have been a link to the actual library file. When you correct the link uae4rpi compiles.

    After installing kick.rom and booting uae4rpi it seems that the keyboard is not recognized. No keyboard press is registered and I cannot access the settings menu. Does anyone else have this problem?

    #2980

    petrockblog
    Keymaster

    Thanks!

    I will update the SD-card image soon!

    #3414

    masterehm
    Participant

    @petrockblog,

    did you fix this? Or have I to do something special here? Everyone is talking about a menu, after the start of uae4rpi, but there isn’t one.

    In directory /home/pi/RetroPie/emulators/uae4rpi there is the executable uae4all. Is this correct? uae4rpi != uae4all
    If I start uae4all without the kick.rom file, I see only a black screen which leaves back to terminal. According to the documentation (docs/README), the emulator should work without the kick.rom file.
    Regardless of the above, with the kick.rom file I see the “Kickstart Boot Picture”. And thats it. No menu. I can’t only reset the emulation (TAB+r) or quit (TAB+q).

    I had only success with the floppy file named df0.adf. Thats my renamed gamerom.

    Is this whole thing a bug or am I doing something wrong?

    #3462

    jzp74
    Participant

    @masterehm

    – I do not see a menu after starting uae4rpi as well
    – uae4all does not work without a correct kick.rom file as far as I know
    – my keyboard does not appear to be working either. I seem to remember that F10, F11 or F12 would call the menu but its a bit hard without a working keyboard 🙁

    Apparently not a lot of people are using the pi for Amiga emulation. I posted several questions about these issues on several different forums but didn’t get any response. That’s very unfortunate coz I was hoping to play some awesome Amiga games on my couch…

    #3470

    captaindork
    Participant

    Hi,
    for me uae4rpi works. At least if I leave emulationstation and start it from CLI.
    I can confirm that I also cannot find any kind of menu, but by using the df0.adf process Roms load fine. (Keyboard also works)
    What I basically do is using links… So something like “ln -s roms/barbarian.adf df0.adf”.

    What I am wondering is why it is not integrated into emulationstation. Any specific reason? Anyone tried?

    #3480

    petrockblog
    Keymaster

    If you find a good solution for starting adf files from within Emulation Station I would be glad to get hear about it!

    Also, feel free to update the information in the wiki at https://github.com/retropie/RetroPie-Setup/wiki/Amiga-emulator-%28UAE4All%29, if they contain any misleading information.

    Unfortunately, I won’t find time for that in the next weeks.

    #3638

    oldbitcollector
    Participant

    @captiondork,

    Could you expand on your solution (work around) a little? I’m in the same boat as others with TAB-Q and TAB-R working, but little of nothing else.

    Thanks
    Jeff

    #3729

    frogx
    Participant

    I have the same problems… No menu in the emulator… Only the boot picture and no working keyboard… How can i get the emulator working without renaming the game-disk files. Many games have more than one disk file… Then i have a problem. Please compile a working version of the uae4rpi… Please please please…

    Greets and wonderful christmas days
    frogx

    #3730

    captaindork
    Participant

    Sure!

    So what I did is:

    – Having run the RetroPie Setup Script (the binary mode) which also installs uae4all
    – copied my kick.rom file to /home/pi/RetroPie/emulators/uae4rpi/
    – copied sample.adf file to /home/pi/RetroPie/roms/amiga/
    – when emulationstation starts, exit it with F4 to return to CLI
    – run “cd /home/pi/RetroPie/emulators/uae4rpi/”
    – run “ln -s /home/pi/RetroPie/roms/amiga/sample.adf df0.adf”
    – run “./uae4all”
    – uae4all will then pick my df0.adf which is linked to sample.adf and run it

    Regards
    captaindork

    #3731

    captaindork
    Participant

    And to share with you how I integrated it into the emulationstation menu:

    First of all: I am no Linux and scripting person, so please excuse if this is not very clean… This is just the result of 2 hours google work… at least it works well for my setup and i am happy with it, but no guarantee for any other setup… 🙂

    Step 1:
    I created /home/pi/Retropie/emulators/uae4rpi/uae4rpi.sh with following content:

    
    #!/bin/bash
    UAEPATH=/home/pi/RetroPie/emulators/uae4rpi
    rm -fr $UAEPATH/df*.adf
    case $1 in
      *_disk1.adf|*_disk1.ADF)
        ln -s $1 $UAEPATH/df0.adf
        ln -s ${1:0:-5}2.adf $UAEPATH/df1.adf
        ;;
      *_disk2.adf|*_disk2.ADF)
        ln -s $1 $UAEPATH/df1.adf
        ln -s ${1:0:-5}1.adf $UAEPATH/df0.adf
        ;;
      *)
        ln -s $1 $UAEPATH/df0.adf
        ;;
    esac
    cd $UAEPATH
    ./uae4all
    

    (do a “chmod +x uae4rpi.sh” to mark it as executable)

    Step 2:
    I added the following lines to /home/pi/.emulationstation/es_systems.cfg

    
    DESCNAME=Amiga
    NAME=amiga
    PATH=/home/pi/RetroPie/roms/amiga
    EXTENSION=.adf .ADF
    COMMAND=/home/pi/RetroPie/emulators/uae4rpi/uae4rpi.sh %ROM%
    PLATFORMID=4911
    

    This made a nice menu available in emulationstation where I can browse my adf-files, select them and they get started properly, just as for any other system. TAB+Q will return to emulationstation. Perfect!

    Be aware, that adf-files ending with “_disk1.adf” will assume that a “_disk2.adf” is present and will insert this second one automatically into df1. So if you exactly follow this naming convention, also roms with 2-disks will work.

    Regards
    captaindork

    #3734

    frogx
    Participant

    Wow…
    What a fast answer…
    Does the script works with a 5 disk game (elvira)?

    Thanks a lot!

    #3736

    captaindork
    Participant

    Hmm well,

    as uae4rpi only shows df0 and df1 (the green icons in the lower right) I feel only df0 and df1 work with my workaround (I also only prepared the script for 2-disks). I have read you can configure more df’s in the menu of uae4all, but as I also still am not able to get into this “menu”… so no 5-disk for now…

    But at least most 1-disk and some 2-disk games work fine from within ES. Also with 2 gamepads, keyboard and mouse… tried some games today, real fun, even if I have seen better amiga emulation experience regarding speed, sound, graphics…

    Hopefully development for uae on the rpi continues 🙂

    #3737

    frogx
    Participant

    I hope so, too!!!

    Uae is the most important emulator for me on the rpi!

    Thank you very much for your help!!!

    I will inform you when i have tried your script these days and when it works!

    #3738

    frogx
    Participant

    Which version of uae4rpi is the newest one?

    #3740

    frogx
    Participant

    On wich position do you have entered your step 2 in es_systems.cfg?
    I had it on position 2 after apple 2,
    then all other emulators would not work one more time.

    Ever i start an other emulator it will be startet one like
    a commodore 64.

    greetings…

    #3742

    captaindork
    Participant

    I had it at the bottom, but now having it as first entry. Both working fine, also all other emus work. At least I tried Duke3D, NES and SNES.

    Anything else that could have happened? Which editor did you use? Try editing the cfg only on the raspberry using nano. Eliminate all unneccessary spaces, etc…
    Don’t use windows notepads (because of ANSI encoding).

    #3750

    frogx
    Participant

    I have used nano…
    Mmmh… Well, i will try it again 🙂

    The other methode works fine 🙂 #3730

    #3763

    chrisl
    Participant

    Hello @all.

    I am trying to get the UAE working. I used the scripts from captaindork and tei work great.
    My problem is, that I don´t get a picture. Sound is working, when I start Adams Family.
    I also tried to use another uae4rpi binary from web, but there the menu is shown all the time.

    Do you have any hints?
    Thanks

    #4253

    captaindork
    Participant

    Thanks for the Feedback!
    Did you try some other ADFs to ensure it is Not related to a particular game Rom?

    #4277

    brucelee1972
    Participant

    Hello Captaindork,
    great work.
    Have used the instructions from the post # 3731
    The 1 disc games run great with me.
    Sound is running a little slow but the game speed is good.
    However, the 2 disc games run not with me.
    Get the message “insert disc 2” in games such as eg. Wolf Child, Shadow of the Beast 2 and 3, Turrican …..
    The problem is that at that time many games were only on the internal floppy.
    Is there the possibility to insert disk 2 in df0?
    Sorry for my bad english.

    #4278

    brucelee1972
    Participant

    Can you. Hdf files use WHDLoad games to start?
    Then the problem would have done with the disk swapping.
    I have for example on the PC. a hdf partition with the workbench and another hdf partition with all the games.
    How can I integrate the two partitions so that the Workbench starts and I get the games from the second can start hdf partition.
    I hope you can help me.

    #4344

    asiainorama
    Participant

    Hi captaindork, I’m very grateful with your work.
    I follow your steps and now I have my list of games on TV, but I still having a problem…
    When I select one game, try to open it and after, it’s closed.
    Do you know what can be the problem? Is possible that I have done something wrong, because I don’t know code. 🙁
    I hope you can help me.

    Thanks

    #4351

    captaindork
    Participant

    Hi all,

    @brucelee:
    You are absolutely right, all 1-Disk Games work fine, 2-Disk Games only if they were made to support a second drive (df1), which actually were not much games in the old times.
    Key to make all working in a more clean way is IMHO still to fix the whole port for the rpi, as usually a menu is available in uae4all which will allow to swap disks, which seems not to be accessible on the pie implementation. I also did not read into hdf for now, but also feel first the menu should be fixed for RetroPie.
    So my Scripts are only a “workaround” to make 1-Disk Games work and some 2-Disk ones…

    @asiainorama:
    Hmm hard to guess the issue but:
    – did you copy a working kick.rom as mentioned in #3730?
    – did you perform the “chmod +x uae4rpi.sh” in the shell?
    – could you check the manual steps in #3730 as the script basically does the same. Just share your Output if Errors occur during the manual way.

    #4352

    asiainorama
    Participant

    Ok, finally I’ve solve it. The problem was the format of uae4rpi.sh. I’ve modify it with xcode and now works.
    I’m using kickstart 1.3 because I had Amiga 500.

    Observations:

    1 – Sound don’t work any game.
    2 – Games work only if the name is one word. Example:
    – Wrong: Bubble Bobble.adf
    – Good: BubbleBobble.adf

    I hope my comments help someone.

    Regards.

    #4382

    asiainorama
    Participant

    Other observation:

    The PS2 controller doesn’t work, but the same controller work fine with NES games.

    #4392

    captaindork
    Participant

    Well sound works for me, but actually I didn’t do anything special to make it work, therefore I have unfortunately no clue how to help…

    For the gamecontrollers, I use SNES Controllers connected to the GPIO and the gamecon drivers. I had this setup already before using uae.
    However, no amendements were needed, they just worked with uae.

    #4396

    asiainorama
    Participant

    I don’t know why, but Amiga games are working with the second player controller not with the first.

    About the sound, I’ve read this:
    Audio IS emulated, however it doesn’t work over HDMI for some TV display…

    #4433

    asiainorama
    Participant

    Hi again!!
    Do you know how to see uae4rpi on fullscreen?
    I’m trying the Chips’s version of uae4all and it works directly on fullscreen.

    #4642

    pnow
    Participant

    EDIT EDIT EDIT:

    Sorry for the wrong information I supplied, I was misled by the background of the emulator I’m using, saying “Amiga emulator by Chui” and displaying a “Dreamcast Amiga uae4all” logo. Since, as I said, I couldn’t remember exactly where I got hold of the emulator I had just googled Chui’s emulator (whose page looked familiar) and posted the link to it.
    The emulator I’m using is exactly the same one user “asiainorama” linked to above. As far as I understand it’s a modded version of Chui’s Dreamcast emulator for the RPi.

    Get this one!

    ORIGINAL POST:

    I had encountered the same bug upon installing RetroPie 1.8.1.
    With no Linux knowledge whatsoever I spent a lot of time searching for a solution on the net – I don’t know where I came across my final solution (possibly I did on here), but this has been working on my Pie for quite some time now:

    Chui’s Dreamcast emulator (http://chui.dcemu.co.uk/uae4all.html).

    Some random games don’t seem to work, but I’d say at least 95% of my collection run without any problems.

    Also, there wasn’t any trouble configuring anything, mouse and two-player joystick support were available straight away.

    #4643

    sunjammer
    Participant

    @pnow:
    That’s interesting! What exactly have you done in order to get the amiga emulator working? Have you downloaded the source code and compiled it on the Raspi?

    #6352

    chrisl
    Participant

    Hello.

    After rebuilding everything from sources, my UAE works.
    I just have the problem, that UAE4RPI won´t use the df1.adf.

    Do you have any hints?

    #6377

    Mutex
    Participant

    I switched to the uae4all by chips.
    It has a working GUI, so you can easily change the disks during play.

    It runs okish with the cyclone binary. I had some heavy frameskipping when the emulator was still loading the disks. But every game that I tried so far works pretty good.

    I tried to get the uae4rpi working but never got the keyboard to work.

Viewing 35 posts - 1 through 35 (of 40 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.