Nintendo 64 Emulator not working – Segmentation Fault

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Nintendo 64 Emulator not working – Segmentation Fault

This topic contains 3 replies, has 3 voices, and was last updated by  gizmo98 3 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22901

    viralriver
    Participant

    Hi, I have recently installed RetroPie using the latest image onto an 8gb micro sd (I’m using a B+ pi).

    Initially I transferred over some GB roms, and they work perfectly. I then tried some GBA roms, and they didn’t work but after transferring over the gba_bios file, they worked.

    Finally, I now want to run N64 files but I cannot get them to work. I have transferred over Pokemon Stadium, and on selecting it in the ES menu, the screen resolution changes and then I get the message:

    /opt/retropie/supplementary/runcommand/runcommand.sh: line 23: 2335 Segmentation fault ./mupen64plus /home/pi/RetroPie/roms/n64/Pokemon\ Stadium.z64

    I have seen someone else posted this problem on this blog but no resolution was found. I tried to reinstall the mugenplus emulator via the retropie_setup.sh file, but it gave me an error after about 30 minutes of execution.

    If anyone knows how to fix this please let me know! Oh and I’m not too confident with the terminal, so please explain everything thoroughly 😛 .

    #24939

    mr9v9
    Participant

    Bump
    I’m suprised that this issue has not been resolved and there are 3+ posts about it. From what i have read the guy who was forking the build from official repos has depreciated the project so it’s not as confusing.
    The build process is the same, but I can’t test it on the RetroPie right now>

    To setup, run the following commands:

    sudo apt-get install git # to install git if you don’t have it.
    git clone http://github.com/ricrpi/mupen64plus # to clone the repository
    cd mupen64plus
    ./build.sh # to build the binaries and shared libraries
    sudo ./install.sh # to install mupen64plus into /usr/local/bin

    You can also try reading my post on the bottom of this page if it won’t compile. Like I stated I haven’t had a chance to test.

    #25379

    viralriver
    Participant

    On the build I get the following error:

    *****************Changing branch from master to ric_dev for mupen4plus-core
    Branch ric_dev set up to track remote branch ric_dev from origin.
    Switched to a new branch ‘ric_dev’
    Not enough memory to build
    Please set CONF_SWAPSIZE to >= 404 in /etc/dphys-swapfile and run ‘sudo dphys-swapfile setup; sudo reboot’

    This is after a lot of ‘cloning’ it just stopped with the above message. I SCPed into the mupen64plus directory under home, but couldn’t find any directory called ‘etc’. Any advice?

    #25556

    gizmo98
    Participant

    Your swapfile is too small. Try this:

    Mupen64plus (ricrpi branch)

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss