Nintendo 64 emulator doesn't work!

Home Forums RetroPie Project New to RetroPie? Start Here! Nintendo 64 emulator doesn't work!

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of sofia sofia 1 year, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #102322
    Profile photo of sofia

    Hi guys,

    I’ve got a new Raspberry Pi 2, with RetroPie 3.0 beta from SD card image, and all of the emulators and roms that I’ve tested just worked beautifully, except one: Nintendo 64 games. They are unplayable: very slow and the sound keep stuttering like crazy. I’ve been seeing at the internet people performing n64 games on RPi’s 2 perfectly, so I know it’s possible.

    I set the overclocking to “Pi2”, and tried to change the video settings but I didn’t see any difference.

    What could I’ve been doing wrong?

    Thanks in advance 🙂

    Profile photo of gutossn

    I’m using Mupen64Plus and works fine! Super Mario 64, Mario Kart 64, Diddy Kong Racing and Banjo Kazooie works great! USA version must be used. The power supply gives 5v and 2a?

    Raspberry Pi2 and Retropie 2.6.

    Raspberry Pi B+ - Mini Bartop Arcade - Retropie 2.6!

    Raspberry Pi 2 + PS3 Controller Wireless - Retropie 2.6!

    Profile photo of sofia

    Yeah, the power is all right.. I guess I’m using Mupen64 instead of Mupen64plus, it didn’t come pre-installed on my RetroPie.
    Do you know how could I change that?

    Profile photo of herbfargus

    Press x or m as the ROM loads and you can change the default emulator. Or in the experimental menu from the retropie setup script you can install mupen64plus testing which seems to have better configs for running games but it will still be hit and miss.

    Profile photo of sofia

    Yes, was an emulator problem! I’ve tested each one until I found one that works (Mupen64plus) ^^
    Now I just have to configure the controller all over again hahah

    Thank you so much! 😀

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar