New Xbox One Controller (2015) not working

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie New Xbox One Controller (2015) not working

This topic contains 1 reply, has 1 voice, and was last updated by  drsternau 1 year, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #110071

    drsternau
    Participant

    When I plug in the new model of the Xbox One Controller (the one with the audio jack) the system freezes. The problem is caused by the xpad driver, which does not recognize the device id. The problem was already addressed and solved in the official Linux kernel (by adding one line), but not for raspbian/retropie. This is described here: https://github.com/torvalds/linux/commit/39a7a88872df98f0c3c50fe278fd1a1f597afd95

    I tried everything I could think of to update the xpad driver for retropie with no luck. Can somebody please help me out?

    #111412

    drsternau
    Participant

    Yeah, I found a solution and will post it here.

    The only thing to do would be to update the xpad driver (from here: https://github.com/paroj/xpad)

    However this failed because of missing linux headers.

    Which I found, downloaded and installed from this site: https://www.niksula.hut.fi/~mhiienka/Rpi/linux-headers-rpi/

    With installed linux headers, I could update the xpad driver without any problems. After a reboot, retropie and the xbox one controller 2015 finally worked together. All was well…

    In my specific case (I’m using a Raspberry Pi 1B, and Linux 4.1.7+ which I obtained by running “sudo rpi-update”) the steps would be as follows:

    wget https://www.niksula.hut.fi/~mhiienka/Rpi/linux-headers-rpi/linux-headers-4.1.7%2B_4.1.7%2B-2_armhf.deb
    sudo dpkg -i linux-headers-4.1.7%2B_4.1.7%2B-2_armhf.deb
    sudo git clone https://github.com/paroj/xpad.git /usr/src/xpad-0.4
    sudo dkms install -m xpad -v 0.4
    sudo reboot
Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/