New user/retro pi setup issues

This topic contains 4 replies, has 2 voices, and was last updated by  zsprawl 3 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12514

    iam8up
    Participant

    I have a B version Pi and just set up a new RetroPi. I grabbed the full image (this is remarkable, by the way) and booted it up.

    1) I put some SNES roms on and ran into performance issues like everyone else. As the (very useful) thread suggested at 2.2 step by step guide I switched to pisnes for emulation. Originally, I tried commenting the first two commands – this gave me a black screen. Currently I just deleted the two and it now starts.

    However, my issue is that the controller commands do not work. I tried both a straight copy from the thread as well as matching my settings that I got from /opt/retropie/emulators/RetroArch/installdir/bin/retroarch-joyconfig (these settings work for the ES menu and the out of the box SNES emulator). I am using a wireless Xbox 360 controller and the official dongle.

    2) Should the out of the box GBA emulator work? None of my games run.

    3) How can I enable a turbo button for a game (specifically Pokemon Blue on GB)?

    As a side note, Cave Story seems to crash any time I load a saved game. I don’t care if this works for me or not, but I did want to note a symptom. Doom appears to run perfectly fine.

    #12520

    zsprawl
    Participant

    1) Nothing on your controller works at all? Not sure whatsup… does it work in other games? You may want to overclock your Pi and keep the original RetroArch SNES emulator.

    #12585

    dem1980

    2) GBA emulator need a gba_bios.rom to run

    #12718

    iam8up
    Participant

    1) Nothing on your controller works at all? Not sure whatsup… does it work in other games? You may want to overclock your Pi and keep the original RetroArch SNES emulator.

    For pisnes the controller doesn’t work at all, no. It did work on the RetroArch emulator (if this is what is used by default). I am waiting on aluminum heat sinks and a case before doing any overclocking, but this may be the best solution.

    2) GBA emulator need a gba_bios.rom to run

    I did find this file online and the byte length did match what the emulator originally complained about. After placing the file the error went away, but it fails at this point.

    #12758

    zsprawl
    Participant

    If you can’t get pisnes working based off my writeup on the other thread, then overclocking might just be an easier solution. I actually have since gone back to the original RetroArch snes emulator after overclocking, and it run fantastically.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss