New to Retropie and Linux in general – couple of questions

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! New to Retropie and Linux in general – couple of questions

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 10 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #103496
    Profile photo of maplicito
    maplicito
    Participant

    I only just got Retropie up and running last night, so I haven’t had much of a chance to do anything yet. I’m also very new to Linux based systems – my only exposure was over a decade ago, and was very brief – but, although I’m long since removed from MS-DOS, I did have a lot of experience with it, so I’m not entirely new to command lines.

    Anyhow – first question – USB syncing. I have successfully gotten ROMs onto my pi, but I’m wondering about removing them. I’m not home, so I can’t try this right now, but if I remove ROMs from my USB drive, will the pi sync by removing any ROMs that don’t exist on the USB drive, or does it only add from the USB drive.?

    Second question – I have a TP-Link TL-WN725N (don’t know if it’s V1.0 or V2.0). I could not get it running. Running the lusb command, I could see my gamepad, and I could see my keyboard, but I couldn’t see the wireless adaptor. Going though online tutorials didn’t make any sense – it could be that I was sleep deprived, and they’ll make more sense to me when I go through them again.

    My first thought is that the adaptor requires more power than my pi can provide, and that I need to run the adaptor off a hub. Is that likely? Or is there something else I need to do to get the pi to recognize the adaptor, and get it running?

    Thanks!

    #103497
    Profile photo of herbfargus
    herbfargus
    Member

    I haven’t tried the ROM syncing thing so I wouldn’t know about that but the wireless adapter you’re having problems with is known to have problems… You might have better luck just buying a new one, or you can attempt to install the drivers it needs

    http://smartretro.co.uk/forums/viewtopic.php?t=50

    #103500
    Profile photo of maplicito
    maplicito
    Participant

    Thanks for the response. I might just get a new adaptor… this is one I borrowed from my sister, so I was planning to get a new one anyway. Does anyone know of a list of adaptors specifically supported out of box by Retropie? I have tried looking at a few different lists, and the only one I could find confirmed was the Adafruit wifi adaptor, but I haven’t found any lists specific to Retropie.

    Thanks again.

    #103501
    Profile photo of herbfargus
    herbfargus
    Member

    This is a general WiFi dongle list:

    http://elinux.org/RPi_USB_Wi-Fi_Adapters

    I use one that came as part of a canakit but there are lots that work.

    #103502
    Profile photo of maplicito
    maplicito
    Participant

    Thanks! If anyone knows the answer to the USB syncing question, I’d still be curious to know… if not, I’ll find out myself later.

    #103516
    Profile photo of funigui
    funigui
    Participant

    I use the canakit WiFi adapter and it works great. As far as pushing and pulling roms, hook into the network and use winscp, its effective and familiar to most people.

    Sent from my SM-N900T using Tapatalk

    #103573
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    I will second the Winscp sentiment, you can pull files off if you go into the directory and use the command ” rm *file name* ” then enter

    #103574
    Profile photo of maplicito
    maplicito
    Participant

    Thanks for the response. I ended up just blowing away the image, and getting the Retropie 3.0 image, so all the games I wanted gone are gone anyway.

    Something else I have ran into – every Atari 800 game I try to run, I get a screen that tells me that “this game needs a real Atari machine” – is that a problem with the ROMs, or do I need to do something to configure the emulator?

    #103575
    Profile photo of herbfargus
    herbfargus
    Member
    #103576
    Profile photo of maplicito
    maplicito
    Participant

    Thanks again. I take it some of the emulators come with whatever files are necessary, and some of them have an install entirely separate from the BIOS? I had wondered if I needed to do that, but since I was running N64 and Sega ROMs just fine, I thought I must not.

    Thanks for having patience with a noob!

    #103577
    Profile photo of herbfargus
    herbfargus
    Member

    not a problem, happy to help- some systems need a bios file (think of it as a file that gives the emulator permission to run) the wiki will always note if the system needs a bios and what the file names should be called. The bios files can’t be legally included with the retropie project as they are copyrighted by the original companies, so those are up to the user to supply themselves.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar